Key press trigger

Hi,

I am trying to set up a Trigger that allows for users, should they so wish, to press either the right or left arrows on the keyboard while watching a 360 course, and have it navigate between slides, image of trigger below. I'm setting it in the Slide Master to avoid slide-by-slide entry.

Problem is, it does not seem to work.

Could someone please check this for me, and confirm if this is a bug or not?

Thanks

21 Replies
Crystal Horn

Hi guys!  We just released another update for Articulate 360, and included a few important fixes and new features that you'll see in the release notes here.

We fixed some triggers that didn't always work correctly in HTML5 output, including triggers that execute when clicking outside an object, key-press triggers, and conditions that compare two numbers.

Just launch the Articulate 360 desktop app on your computer and click the Update button for each application.

Let me know if you have any questions, or feel free to reach out to our support team!

Crystal Horn

Hey everybody. I'm excited to let you know that we just released update 3 for Storyline 3! It includes new features and fixes - check them all out here.

One of the fixes addresses an issue where the trigger "when user presses a key" was not functioning unless you pressed the Tab key first.

Here’s where you can download and install the latest version of Storyline 3. Let me know how you make out!

Benedict Manuel Barbieto

Hi guys, I need help, I cant seem to get my key press trigger to work :(.  i am talking about Scene 1 Activity, When i go to  preview mode, the click trigger works to click a letter and it change state to disabled. But the key press trigger is not working. But if i click replay, it works!

 

I need help please.

Crystal Horn

Hi there, Benedict.  No sad faces.  ☺️

I noticed in Preview that pressing the letter key wasn't working unless I tabbed to the letter key on the slide.  When I looked at the triggers, they were set up so that the "Object" option was specific to each letter.  That means that the focus has to be on the letter for the trigger to work. In other words, I have to tab to that letter, and then press the letter key.

Try changing the Object field to the slide.  The focus is already on the slide, so pressing the letter keys should allow the triggers to fire.  You'll have to change any triggers associated with pressing the letter keys.

Let me know how that works for you!

Peter van der Slikke

Hello,

Experiencing the same issue but with a slightly different approach:

I want users to be able to click 'n reveal layers by either clicking a button(shape) or a (number)key (1-9).

This works. 

I also want them to be able to hide the layers the same way (click a button or press the '0' key.

This does not work. Only works with Wendy Farmer's 'workaround'.

I have set up the trigger as Chrystal suggested.

Is this still a bug? Should i report?

For now: can anyone think of a real workaround (where users don't experience the issue)?

Ramon Smitherman

Maybe I am not fully understanding the issue but I am able to use the same key to toggle between the base layer and another layer.

I set up a trigger in the master slide which used the F12 key

"Toggle variable Toggle_layer
  when the user presses the F12 Key"

Then on the slide I put a trigger on the base layer to show layer1 when toggle_layer changes
If toggle_layer is equal to True

On layer 1, I have a trigger that says
Hide layer this layer
When toggle_layer changes
If toggle_layer is equal to False

Peter van der Slikke

I'm sorry that i'm not explaining my self good enough...

I am not using the same key to return to the base layer. I use keys 1 to 9 to show the layers.

I use at each layer key '0' to hide the slide. Just to be sure i changed this and gave each layer a hide layer trigger with a different key (q to o) with no difference in outcome.

Ergo: We can rule out using the same key at different layers is the issue.

Peter van der Slikke

Hi!

Thanks for your reply. Let's hope then if it's something odd from my side :-)

Here it is. The test scenario would be:

  1. click on 1 of the 3 buttons. (don't use the 1,2 and 3 keys at this point)
  2. press the '0' key (on top) of your keyboard (not the num key at your right)  - my outcome is that this doesn't work... 
  3. click somewhere in the screen
  4. press the '0' key once more - now it works
Ren Gomez

Hi Peter,

Thanks for sharing your file! I jumped in and was able to confirm the issue using your steps. By using the tab key, I was able to figure out that the focus was staying on Button 1 in the base layer, even when Layer 1 came up.

On Layer 1, if you click on the ⚙️button for your Layer Properties and check the box for Hide objects on base layer, the focus will immediately shift to your layer, and you'll be able to enter 0 to close the layer without having to click on it first. Hope this helps!

Peter van der Slikke

Aha! Thanks. That is a workaround i can use. 

Only minor downside is that i have to copy the contents of my base layer to all 9 other layers to maintain the same look and feel of my initial idea... 

But since this is not something i will use a lot i can do that easily.

Case closed (in my case). Thanks for all support.

David Beaulieu

Hi All,

I am having similar issues.

When I am using the navagion button (next) I lose the focus of the slide and I am enable to have the trigger " When : User presses a key" to work properly without having to click on the slide before. This is a big problem for me.

Is there a bug fix to be release soon?

Katie (Gokhshteyn) Riggio

Hey there, David. So sorry that's happening!

Would you be willing to share a sample .story file with me so I can take a closer look at that behavior? You can share it privately by uploading it here. I'll delete it after taking a thorough look!

Also, what version of Storyline are you using? You can find this detail by clicking on the Help tab, then About Storyline.