Layer audio seekbar

I have several slides that have mulitple layers. Each layer contains it's own audio. I have the layers set up to allow seeking and to hide layer when timeline ends.

Problem: A user watching viewing a layer wants to move the seekbar back to re-listen to audio. The video/layer rewinds to the appropriate spot, but the audio continues to flow without changing. The audio will then end while the layer replays from where it was rewound to.

Solution: ??????

Thank you,

7 Replies
Leslie McKerchie

Hello Tammy and welcome to E-Learning Heroes :)

This conversation is a bit dated, but I'd love to take a look to help you out.

With your permission, I'd like to take a look at your project file to investigate what's happening. You can share it publicly here, or send it to me privately by uploading it here. I'll delete it when I'm done troubleshooting.

Tammy Duncan

Thank you for responding Leslie.

I actually figured it out on my own :)

Originally the audio files were on the base layer.  I think that I moved them from the layers to the base layer because the seekbar wasn't working.  (that was before I knew about setting that option on the layer.)  But when I moved them back to their rightful layers, I was not able to actually see the audio waveform on the timeline.  And the audio did not play automatically when opening a layer.  So I added a trigger on the layer for the audio to play when the timeline started.  That seemed to cause issues.  So I decided to remove that trigger.  When I did, the waveform appeared on the audio in the timeline.  And then, when I opened a layer, the audio played and the seekbar worked beautifully!