Lightbox Slides cut off in Firefox

I am using lightbox slides in a course as the sole way to access information.  When using Firefox all of the lightbox slides are cut off on the right and bottom. All other browsers work fine.

Attached is a screen shot that shows what is happening.

I know of a work around but it would require a bunch of extra work that I would like to avoid.

Any help would be much appreciated. 

Thanks!

8 Replies
Christine Hendrickson

Hi Laura. Welcome to E-Learning Heroes!

First, thanks for the screenshot!

I have some questions for you about this that may help us pinpoint the issue:

  • Is this locally published content (not uploaded to a web server or LMS) or has this content been published and uploaded to a server? Please make sure you're testing the content in the environment for which its intended. Take a look at this article for more information on testing published content. 
  • Is the content being published for Web or HTML5, etc.? Firefox has some limitations with HTML5. Please see this chart for more information (browser information is provided at the very bottom of the list).

Also, was this content previously functional in Firefox? If so, you may want to try clearing the browser cache and see if that makes a difference. 

Laura Seul

Hi Christine,

Thanks for the fast response and the answer to my question.

The content has been published and uploaded to a server. I am using HTML5 so that is the issue and I don't think the content was ever functional in firefox.

I guess I am going to have to go with my work around.

Thanks again for your help!

Sam Carter

Laura Seul said:

The content has been published and uploaded to a server. I am using HTML5 so that is the issue and I don't think the content was ever functional in firefox.


I've seen this Storyline issue.  I'd call it a bug.  If you set Firefox zoom to 100%, the problem is gone.  Zooming somehow compensates all the content except the lightbox in HTML5.  I don't recall if it behaves the same in other browsers.  I'd like to know if you do further testing.

In my case, Firefox was an alternate testing platform to the iPad.  Since the iPad doesn't zoom, this is a non-problem.  

As long as we're talking about HTML5, don't apply audio to slide layers.  The audio won't play in sync with the animations.

Darren Besanko

AH, I am having the same problem, using IE9. If I open the html5 version, the lightbox slides are cut off. If I open the plain 'story.html' file then it works ok (running off hard drive).

If I load to my LMS as a web object the same thing happens, but the html5 plays so that we have iPad compatibility. It works ok on the iPad.

Steve Bunting

Hi Christine

I know they have upgraded Firefox to at least 20. I have advised them to check their Flash version, I have checked 2 computers and mine are set at 11.7.700.202 and 11.7.700.224.

I am waiting for the users reply but hope they need to upgrade which will sort it out.

Thank you for getting back to me.

Steve