Memory Game

Good Morning, 

I am currently working on a memory game. I used the template for download off the website, when I preview each single slide ( there are 3 consecutive) they work and show a review layer when they're matched properly but when I run the whole project together the review layers don't show up on the second and third slides. Any trouble shooting ideas?

7 Replies
Christie Pollick

Hi, Stacy -- First, welcome to the community! We're glad you're here. I also wanted to note when you reply via email, your signature details are displayed publicly here in the forum, so you are welcome to use the EDIT button beneath your post to remove that information if you wish. 

And if you would like to share your file, you have 2 options: #1 - you can use the ADD ATTACHMENT button in the bottom left of the reply box to browse for your file from there, and it will be accessible by the community here in the thread. (This is a great option if you would like a variety of suggestions or different ideas). Or #2 - if privacy is a concern, you are welcome to share your file confidentially using this link and you will be contacted via email once your file has been reviewed. Whichever option makes you the most comfortable! :)

Brian Allen

Stacy,

Slides 2 and 3 are not working because slides 1-3 all (currently) share the same set of variables.

To get this to work you would need to do one of two things:

  1. Create slide specific variables to use on slides 2 and 3.  Sometimes I add slide number to the variable name to help me keep track of them and to make the variable names unique, OR
  2. If you want to use one set of variables for all three slides you'll need to reset the values of the variables back to zero at the beginning of slides 2 and 3.  This is probably the easiest way to go, possibly not the cleanest, but the least amount of work.

 

So, create your triggers to reset your variables at the beginning of slides 2 and 3.

 

Make sure those triggers are first in order on your slide.

 

Finally, you'll have to adjust the following triggers to ONLY show your slide layers IF your variable is equal to "1".

 

Hope this helps!

Christie Pollick

Hi, Stacy -- It looks to me like Brian's suggestion could absolutely do the trick for you, but I did want to mention in the interest of saving time and getting you the help you needed before the weekend, I did create a Support ticket on your behalf last Friday (00681539). It appears that our Support Engineer Wilbert is in the testing phase, so if you no longer need his assistance, simply reply to the email you should have received that you are all set. Thanks!