Moving lines with arrows right after copypasting messes them up

Hello,

wanted to report a bug (probably from the newest update). PS Articulate team, have you ever wondered about bugtracker with votes? You know, you can track what community finds most annoying and needs a repair... that's a win-win situation in every case, right?

If I make line, ctrl+c and ctrl+v it, and then try to move it with arrow or ctrl+arrow, then one edge of the line stays in place and only second moves. You can see the behavior on the video.

However, if you first move it with your mouse, and then use arrows, everything seems fine.

12 Replies
Lauren Connelly

Hello Mateusz!

Thank you so much for bringing this to our attention! I've tested this on my end in Storyline 360 (Build 3.51.24979.0), and it's working as expected, but in Storyline 360 (Build 3.52.25156.0), the lines shift and become diagonal. 

I've reported this bug to my team so we can take a deeper look. I'll update you in this discussion!

Mateusz Szuter

Hi Maria,

I update storyline as soon as I get the notification, so I had the updated version you mentioned.

I've tested on brand new story file (with yesterday update installed) and lines seems to behave normally when moving.

However, in previous project, problem still exists. Also, I've copied the problematic line to my new project and... line again go diagonally when moved. But the new line created behaves normally.

So if the bug doesn't exist for the new projects, that's fine. If it popup in new project, I'll report :) Thanks for information.

Mateusz Szuter

Hello again (to whoever from Storyline staff see this ;))

I've made two new projects recently and in the first glance everything were working smooth. But after some time and work done, the bad line behavior comes back. It won't occur on newly created file (I've just checked). But the file I'm attaching is from like 3-4 days.

The lines don't need even to be grouped, you must just grab line with any other object to move it around, like select textbox and line and try to move - the line will go diagonally after moving. When you select just line, everything goes fine.

I cannot think of the possible behavior why is this happening. I'm attaching the story file. Just try to move the line&some other object with arrows or mouse, it will do diagonally. Move the second one only, without any other objects selected, and it will behave normally. And after that, take that second moved line, select it with another object, move and... it will behave normally, it won't go diagonal. I have no clue :)

Mateusz Szuter

Hi Lauren,

Well, how to say it... It behaves normal for me also, whenever I download it from my post or access it from my computer.

But I opened the original project file and recorded a video. There are problems.

I'd truly want to help WHY is this happening, I just don't have a clue. It's totally random (like my other post with states) now it seems.

 

 

Maria Costa-Stienstra

Hi, Mateusz.

I just wanted to share that we are no longer seeing the bug reported where moving multiple line shapes results in diagonal line shapes using the latest build of Storyline (3.61.27106.0).

If you're using the latest version and you're still experiencing this issue, please reach out to our support team through a case

Mateusz Szuter

Hi Maria,

I'm always using the newest version. Also does my colleague from work.

We have a problem replicating this behavior now, but it pop up after some time in our every project. I'll reach the support team and try to find some solution with them. Thanks :)

BTW the behavior is corrected after first manual adjustment to the wrong line. Like you move it with arrows/mouse, it goes bad, then you just place it as it should be and problem no longer pops. It always moves defined_grid_spacing pixels up and some random number in height. So it's painful but you can work with it.

Mateusz Szuter

I'll just come back to report, that this is still the problem, however I'm struggling to find WHEN this occurs and what causes it.

I've copied the line, pasted it and moved using mouse - everything is ok.

But when I copy it second time and try to modify it width property, it goes nuts.

This happens somewhere in the middle of the project. When you create new project and work from scratch, that's not an issue for some time. It pops after some work is done.

Lauren Connelly

Hello Mateusz!

Thanks for providing these details and screen recording! As you said, it's not consistent behavior so has been difficult to determine when it appears and what the cause is.

The next step here is to have you share your .story file with our Support Engineers. You can do that by submitting a support case.