Moving objects in SL3 with keyboard arrow keys not working correctly

I'm working on a game within Storyline 3 where the learner uses the arrow keys on the keyboard to move a character around the room and pick up items (see attached sample). 

The problem I'm having, is that the arrow keys don't work until you click on the object with the mouse button.  I can only assume this is a SL bug because it's not a behavior a learner would be expected to just know inherently. 

Does anyone know a way to make it so that you don't have to click on the object (in this case an image) before the arrow keys pressed by the learner will work?

Thanks in advance for your assistance on this.

15 Replies
Leslie McKerchie

Hi Liam,

Sorry that you've run into a similar issue and thank you for linking the additional thread as well.

The only workaround we have listed is to click on the object first, which I know is not the experience you wish for the user to have.

We do have this reported and I'm adding this thread as we track user impact and so that we can update you here when we can.

John Smith

Very interesting example Geetha that got me thinking of a new exercise I could do at my organization.  I'm glad you shared it.  I'm not sure I understand how it's related to this thread though - you can't use the keyboard to move the character in that link and that example was made in SL2 not SL3/SL 360.

Katie Riggio

Sorry you've come across this problem, Brett. Happy to help investigate!

Could you let me know what version of Storyline you're using?

  • If Storyline 3, we're still investigating why the keypress functionality and triggered motion paths do not work when the focus is on the slide or object when viewing the HTML5 output. We'll keep this discussion posted as soon as we know more; click here to learn more on how we prioritize bugs like this one!
  • If Storyline 360, we haven't heard other reports of this, so I'm glad you brought it to our attention! Would you be willing to share your .story file privately with me here? That way, I can test your setup to see if we need to take action on a new bug. I'll also delete it after troubleshooting.

Let me know, and we'll explore our next steps from there!