No mouse pointer change when hovering over hotspot

Hi everyone. 

You know how on Storyline1 when you add a hotspot, and if the checkbox for "change pointer to hand on hover" in the properties is checked, the mouse pointer changes to a hand when you hover it over the hotspot? 

Well, the minute I add another hover trigger to anywhere on the same slide (any layer), say, to change the state of an object on the slide, this hotbox mouse-state change is cancelled. 

I've tried adding triggers, putting the hotspots on separate layers, putting the different object states on separate layers, nothing seems to restore the hotspot mouse pointer state change. As long as there is another trigger on the slide that is triggered by the  'hover' state the hotspot mouse change is cancelled.

Can more than one 'hover' trigger not co-exist? Thanks for you help. 

9 Replies
Steve McAneney

HELP HELP!!

This is still not working for me! I KNOW it should be possible to place a hotspot over an object so that when it is hovered over the mouse changes into a hand. In fact, I managed to achieve this very effect in the attached .story file.

However, I don't know how I managed it! I can't replicate the same cursor and state change on hover no matter what I do.

If anyone can compare the two slides in the attachment (one that works, one that doesn't) and tell me what needs to be done to get that darned cursor to change to a hand, please do. Thanks in advance. 

Ashley Terwilliger

Hi Steve, 

Thanks for sharing your file here - I took a look at the file and saw the same behavior in your file. I didn't see anything off in terms of the file, triggers or states - so I tried importing it into a new file to see if it would resolve the behavior and it persisted. I tried to recreate the behavior in a new file and the hand cursor showed on all the hotspots. 

Can you confirm that you're working on your project files as described in these guidelines? 

Steve McAneney

I just reinstalled SL1 using update 8 - same result. Attached is another file built from scratch. The second I add a state change to the hotspot, the mouse pointer stops changing to a hand. 

Although the previous files were stored that synced to our server, I always made sure I was offline when working on the e-learning. So I think I am following the guidelines you linked to.

Any help anyone can provide would be appreciated. I will submit a support request too.

Ashley Terwilliger

Hi Steve,

Thanks for sharing this file - and now I can see how you recreated it and I can see the same behavior in a new file. I do see that the behavior was reported to our QA team and that the workaround shared in SL1 was to change the trigger to when the user clicks instead of on hover if you need to see the hand cursor. Otherwise, the hover behavior will also work without the trigger as detailed here in the definition of states.