Office files wont open in Storyline 2

I have built a short course that includes .docx , .xlsx, and .pdf resources. I have them all stored in the proper location, which is the same file folder as the .story file. When I publish to CD, things go weird. 

I can open and run the course without a problem. I can access the .pdf files without an issue. But I cannot open the .docx or the .xlsx files. 

However, when I  moved the entire output folder onto a network drive, everything works as it should. I then tried to copy the entire output folder back to my local drive and the same files wont work.

Any suggestions?

 

10 Replies
Terry Coe

Thanks for answwering Leslie.

All of the documents are saved to my local  C: drive. They arent on the network drive until I paste the output folder onto the the network drive. I am the author of most of the .docx files.

It seems all the Office based files are behaving the same. In order to keep troubleshooting to a minimum, I have converted everything I can to a .pdf format. But I do have some templates that will need to get to the learner in a .docx format so they can edit then print, or save to their computer.

Leslie McKerchie

I'm glad my rambling made sense Terry :) I have Friday afternoon brain apparently. 

What version of Office are you utilizing? In both instances, the course is published to CD and you are utilizing the Launch_Story.exe file to play the course, correct? Please be sure you're not viewing a local version of the course and are viewing the actual published output.

 

Terry Coe

I am using an enterprise version of Office 2010. I have only published once since this whole thing started.

I get the same results whether i am laucnching from the Launch_story.exe or the Story.HTML file.

Another interesting wrinkle. An IT friend was working on the office side of things. He copied the output folder from the network drive to his machine (an engineering grade device) and it worked perfectly. So I copied the version he had to my desktop and had the exact same issue as before.  Then i thought that maybe it was because it was local. So I put the output folder onto a flash drive and tried it from there. still busted...

Then I tried doing the same process the IT friend did on another developer's computer, and it was still broken.

Gerhard Fenkart

Hi there!
My colleague and I are having the exact same problem in Articulate 360.The lesson is hosted on Articulate Online.

Learners have three buttons they can press. Each button press triggers the "switch to URL/File" option and should open a file I've included.

  • The pdf file opens with no problem. I have 25 students and it worked perfectly on each of their devices.
  • The two other buttons should theoretically open Excel files. Unfortunately, this doesn't work at all on 20/25 student devices (i.e. no consequence of pressing the button). On 5 devices (circa 5), the typical Windows query of "open or save" DOES appear with the appropriate file name. However no matter what you click, nothing happens.

The files are not protected in any way. If I simply provide the dropbox link, students can download them perfectly.

Any tips, wizards?
Thanks,

Gerhard

Alyssa Gomez

Hi Gerhard,

Since you mentioned that clicking the button does result in an "open or save" query, that leads me to think this is related to those students' browser settings, and not Storyline.

From the 5 students who were not able to open or save the Excel files, do you know what web browser they were using? Were they able to try another browser and get different results?

Gerhard Fenkart

Hi Ashley, Hi Allysa,

Thanks so much for your reponses!

>On the 5 devices where nothing occurs, what version of Office or Windows are they using? Is it at all different than the 20 other devices where it works as expected? 

>From the 5 students who were not able to open or save the Excel files, do you know what web browser they were using?

I seem to have formulated this badly, sorry: It does not work accurately on ANY of the devices.

The only difference is that on 20 devices, nothing happens at all (i.e. as if there were no trigger function).

On the remaining five devices, the typical Windows pop-up window asking "Save or Open?" + the filename appears. But pressing an option (be it "save" or be it "open") has absolutely no consequences.

I doubt it can be a web browser issue (considering the large sample). And like the original poster wrote, any pdf file opens perfectly fine. It's only an issue with Office files.