Only First Slider Stop Works

Hello,

I built a slider with 5 stops. Initial position is 1; layers are triggered to appear for each slider stop. The first stop works (the layer appears), but no other layers work. I tried both while dragged and after release, but still no luck. 

The triggers are all using the same variable and the same slider name. 

I'm stumped. Any ideas?

Thanks.

7 Replies
Walt Hamilton

Likely when the layer appears, the mouse loses contact with the slider, especially if you have put a slider on each layer. if you have nothing on that part of the layer, and the slider shows through from the base layer, it should work.

But there could be a bunch of other things causing this problem. If you want to attach your .story file, someone here could take a peek at it.

Amy L.

It is slider 3 variable in the actual course.

I figured out the problem. I used the correct variable in the trigger, but I thought the condition object was the slider name (slider1), not the variable name. Still a little odd that one worked but not others, but that's okay. I wish I could hide all the layers in one trigger or conversely, have a trigger that shows the base layer.

Thanks for looking at this.