Pick One Shuffle (see file)

Hello,

I'm creating a pick one activity where the user has to choose among 3, 4 or more pictures with shuffled answers. The problem is that when answers get shuffled, the pictures do not just exchange places, but also move up and down. Does shuffling mean that one image occupies the spot left by another image, or do images also move slightly up and down?

If you click on Replay on the attached file you'll see what I mean.

Thanks.

7 Replies
Christine Hendrickson

Hi Becky (love the new avatar!) and Manuel,

I took a look as well and I believe it's related to the different sizes of the shapes. Just like Rebecca, though, I'm not sure what caused it initially.

However, if you take a look at the modified file I'm attaching, you'll see that grouping the answers with a shape seems to fix it as well. I left the border on the shape, just so you can see what I'm referring to. This shape is the same height and width, so the answers will remain in the same "level" when they are shuffled. If you wanted to continue using this method, all you'd need to do is remove the fill or line colors from the shape.

Good luck!

Manuel Aicart

Thanks to you both. By the way, I also love Becky's new avatar.

Christine:

In your file I see two slides in story view: the original one I sent you, and a second one (called 2 Testing). When I click on this second slide I see the modified file (with the groupings), where I'm able to remove the fill/line colors. However, when I click on preview, replay the pictures do not switch places (they stay still). I'm not sure what the problem is. Just in case I'd like to learn how to group the answers with a shape as you did. How can I do it?

Christine Hendrickson

Hi Manuel,

Are you using the "Replay" option while viewing that second scene, or the entire project? Try previewing the entire project. Seems to be working fine for me here with the groups and "Replay", but it may be because I'm not using the single slide for previewing :)

Try that out and let me know if that works for you.

For the shapes and groups, I drew a rectangle on the slide that would fit all three objects. I created three duplicates of these rectangles and sent them to the "back" of the slide. I made sure they were all aligned and spaced evenly, then I positioned the answer images on top of the shapes. 

Once you have the answer images on top of the shapes and you have the formatting you prefer, press CTRL and select a shape and answer image. Once you have those two options selected, right click on them and select "Group". You'll see the group form in the timeline. You can name the group, if you'd like, as well. You can select the group(s) you created in the quiz properties afterwords.

Let me know if you have any trouble with this, or any questions :)

Thanks!

Rebecca Fleisch Cordeiro

Hi,

This really intrigued me (I could've sworn I'd done this previously with different size images) and Christine, you're right: apparently it's due to the size of the graphics. I wasn't able to successfully "fix" things a 2nd time in the way I'd described above.

Also, though, an FYI about what you're experiencing, Manuel with Christine's slide. I, too, was surprised that it wasn't reshuffling just by replaying the one slide. So, out of curiosity, I copied the slide to a new scene - not part of a question bank draw - and it replays fine. Just the one slide.

I'm sure that doesn't make sense...but it worked for me .

Tx for the avatar kudos..I'll tell my husband, the "photographer" ;) Taken with my Android phone.