Portfolio Issues with Cloudberry/AWS

Hello,

I am trying to create a portfolio via Tom Kulhman’s post, https://blogs.articulate.com/rapid-elearning/heres-a-free-tool-to-build-an-e-learning-portfolio/.

When in the cloudberry explore for AWS3, I cannot see anything on the My Computer  side when I open the My Articulate Projects and then open my project, except for an “mp.4” player.

Is this all that I copy over to my folder in my bucket? 

Please advise. Thank you so much!

Denise

5 Replies
Denise Malloy

Hi Lauren!

Thank you so much for the help. I really appreciate it.

One more question...

I can't seem to put the bucket policy in, but it is not working (I get an X in Cloudberry).

Here is the policy I am trying to turn into my own:

{
"Statement": [
{
"Sid": "AllowEveryoneReadOnlyAccess",
"Effect": "Allow",
"Principal": "*",
"Action": [ "s3:GetObject", "s3:ListBucket" ],
"Resource": ["urn:sgws:s3:::examplebucket","urn:sgws:s3:::examplebucket/*"]
}
]
}

I have tried using my bucket name (malloydemo) in place of "examplebucket" but I cannot seem to get it working. Please advise.

Thank you again for your help!

Ren Gomez

Hi Denise,

Thanks for the follow-up, and I'm sorry you're running into errors setting a bucket policy on AWS! We don't support web server setups, but it looks like you're running into similar permission issues that appeared on that tutorial.

Tom shared this link with a user running into the same scenario. You can try copying the policy from there and see if it helps with your setup!

Lindsey Brown

Is it ok to use this code? I saw on one site (but not several others) that this might be dangerous? I just want to show my course on my eportfolio. Thanks

{
"Version": "2008-10-17",
"Statement": [
{
"Sid": "AllowPublicRead",
"Effect": "Allow",
"Principal": {
"AWS": "*"
},
"Action": "s3:GetObject",
"Resource": "arn:aws:s3:::your_bucket_name/*"
}
]
}