Potential issue - corrupted PNGs on publish?

Oct 07, 2022

In the last few days only, I have noticed that sometimes when I publish a course, some of the PNG files come out corrupted.

This seems to only happen on images that I am using the ZOOM feature on.

Storyline seems to be doing some pre-processing, and creates two versions of the PNG when publishing - one for the smaller size (this is the corrupted one) and one for the full size zoomed image (this has always appeared fine)

It isnt all the time, in fact, it seems to happen infrequently, but its definitely there. I have tried this on multiple different projects, and different machines, all running version 3.68.28773.0

Has anyone else come across this issue yet?

5 Replies
Andrew Hanley

Hey Phil.

I havent tried it on the version that was released this morning. Will do so to see.

It isnt always the same file unfortunately, but I did think it might be file name (whats the limit now, 240 chars or so?), so I did a bit of reshuffling and renaming of the project file and assets.

Unfortunately, still there.

Cheers for the reply though.
At very least, Ive found a quick way to check for the corruption. Rather than trawling through the entire published course slide by slide, if you open up the <mobile> subfolder, you can quickly see if they are there or not.

Jose Tansengco

Hello Andrew, 

Sorry to hear that you ran into this snag! 

Are you working locally when making changes to your project file? Working directly on a network drive has been known to cause file corruption, so this is something we recommend to avoid doing. 

If you are already working locally, would you be willing to share a copy of your project file here or in private by opening a support case so we can take a look at what's happening with your image files? We'll delete it when we're done testing! 

Andrew Hanley

Hi Joe,

Yeah I always work locally, never on a network drive.

However, I  wonder if this is something to do with my raid setup though?
My Storyline has always been prone to just crashing to desktop without warning but - just like the PNG corruption - only when publishing.
I reported this to Articulate and have had engineers screen share with me and see the crashing for themselves, but we didnt get anywhere. Its just something I have had to live with :(

My setup isnt abnormal I think. An M2 drive C: and then a raid D: 3 Tb working HDD.
Storyline is installed on C along with all Windows, programs etc.
And my client's work and all assets etc are installed on D.
But this is all local physical drives on my machine.

incidentally, copying the project file and assets to the C: and publishing direct from there neither solved the PNG corruption, or the crashing when publishing.
So Im at a loss (along with all the Articulate engineers!)

If you still feel up for the challenge, I'll happily open up a support case.

Thanks.  Andrew