PREV NEXT buttons appearing when they should not - SOLUTION FOUND!

I just posted this below, but will keep in case others need this info.

I ironically found a solution after a couple more tests.  Here is what I did to fix the issue below.

I had in my 'Player' settings, the 'Seekbar' checked.  I decided to uncheck it in the Player, and then control if I want it or not on a per slide basis.  A little bit of a pain, however it fixed my issue of the PREV/NEXT stock Storyline player buttons from appearing on 'revisit' to my slide when I don't have them appearing anywhere in my course.   I also had to set the question back to 'Reset to Initial' state as I saw someone else mention.  It won't work unfortunately if you set it to Auto or Resume :0(   

Hope that helps.

 

 

------------------------------------------------------------------------------------

Hello.  I have a course with custom previous and next buttons.  I have shut off the default PREV/NEXT buttons in the Seekbar, as I have the bar appearing because I am using the scrub bar for audio, but leaving off the PREV/NEXT since I have my own.

Here is the issue:
I have a slide with graphics/text/audio and Slide Properies on that slide with only 'Seekbar' checked, again no 'Prev' or 'Next' checked, as I am using my own.  

When I go to the next slide, I have a T/F question using Storyline's question model (and Slide Properties set to no 'Seekbar', no 'Prev', no 'Next' in the Slide Properties.  This slide again does not use the built in PREV/NEXT.  

When I leave that slide with the T/F question, and come back to it (I tried all three revisiting options), the PREV/NEXT buttons appear on the bar, even though I don't have them included on that slide, and no other slide in the course is using the built in PREV/NEXT.  I have no triggers either pointing to the built-in PREV/NEXT.

Anyone know how to keep those buttons from appearing on revisit?  Thank you.

Buttons

10 Replies
Leslie McKerchie

Hi Jeff! Thanks for popping back in with an update and sharing with the community.

Here is our documentation on this behavior. Sounds like you found a workaround.

When learners review a quiz, they'll see Articulate Storyline's built-in Prev and Next buttons in the lower right corner of the player—even if you've disabled them throughout your course. See this article for more information.

Ashley Terwilliger

Hi Selene, 

Sorry, you've hit a snag with your content! Are you seeing the prev/next button on review as others in this discussion shared? If so, that's expected so that learners have a way to navigate through the course. 

I don't know if Jeff or others were able to determine a workaround, but you can also message them directly using the Contact Me button on their profile in case they're able to share.

If you've run into something different than described above - can you let us know a bit more detail and what version of Storyline you're using? 

Phil Lord-David

Hey - has this been fixed or a fix found yet? Same issue all SL buttons disabled all good on first visit to question slide. Buttons appear again when learner visits the slide again.

Tried auto decide and resume saved state on the question slide but when the learner goes back to the slide the built in buttons appear again. Tried resetting all player settings, still same issue.  It's not the 'review' functionality just purely going back to the question slide again so the learner can see the feedback again if they wish. This really needs to be fixed it's such a bad UX. 

Anyone got the answer please?

Vincent Scoma

Hi Phil,

I am sorry to hear that you are running into this snag! 

If you are able to share your Storyline file with us, we're always more than happy to help! You can share files in this thread or you’re always welcome to them privately here. We'll let you know our findings and will delete it after having a closer look!