Problems with a Visited State and Motion Trigger

Hi there - I'm building a course that will require users to view information before continuing.  Essentially the learner's path would be like this: four buttons on a slide represent different four topics (Overview) and clicking each button jumps to a new slide which contains the content for that topic (T1, T2, T3, T4).  Once on the topic slide, there is a white space at the top of the slide to show content and there are 6-8 buttons below it, each of which displays a layer that contains a text box filling the space. The learner clicks through the bottom buttons to view the layers and when done, clicks a "back to over view" button to return to the Overview slide.  I have the Visited state of the four main buttons on the Overview slide set show a checkmark when in the Visited state.  The function works for button 1, 2, and 3 (click the button, it jumps to topic slide, explore the topic slide content, and then click "back to over view" and now the visited state of the button shows). The problem is Button 4.  As soon as you click it, the Visited state shows on the screen very briefly before it jumps to the coordinating topic slide.  This doesn't happen on Button 1, 2, and 3. Does anyone know why this happens on Button 4 and how I can fix it so it doesn't show until you return to the Overview (the way it works for Button 1, 2, and 3)?   The second issue is my motion trigger on the Overview slide. A rectangle moves from off screen into view when all four Buttons are in the Visited state.  The motion works as planned, but when you move the cursor, it starts over and I can't figure out why the motion is being triggered again and again.  I've included the source files.  Any help would be immensely appreciated!

thanks,

-Lori

1 Reply