Publishing Storyline 2.0 for the iPad doesn't work - errors, errors, errors!

Mobile version works great, but when we try to view on iPad, we get the message "unable to connect to server".

This is when I published using the settings:

  1. LMS, Include HTML5 output, Use Articulate Mobile Player for iOs or Android, Allow downloading., LMS: Tin Can API.
  2. So, I tried LMS, Include HTML5 output and LMS TinCan API (without the Mobile player option ticked). When I upload to Litmos, I receive the message: Failed Tin Can manifest file error: Please use the unique activity id on Tincan manifest file(tincan.xml)

(I tried renaming it and that didn't work.) Note that our Litmos IS password protected. We must all log in to it.

I am not a programmer type, so if anyone can help me in plain English, I would be most grateful.

In summary: we want to publish STORYLINE 2.0 TO LITMOS and view on iPAD Model MC770X/A version 8.4

Thank you, Articulate community!!

image attached.

29 Replies
Andrew Downes

Hi,

Did you set the activity id in the publish settings? Storyline calls this "identifier" and the setting is just below the launch url. http://www.articulate.com/support/storyline/publishing-articulate-storyline-content-for-tin-can-api

There's some tips on coming up with a good activity id under the "Get the Activity id right" section here: http://tincanapi.com/content/

Chris Cassarino

Hi All,

I am having the same issues as OP, but had a questions regarding the launch URL.  Since i am still having similar errors, i checked the launch URL and it shows as:  story.html

Could this be affecting the upload and reporting?  the article show the launch URL being shown as an actually http or https address.

Any help would be appreciated

Andrew Downes

Hi Chris,

I don't want to contradict Articulate's support article for their own product, but I would expect that a launch URL of "story.html" (i.e. a relative URL) is the most sensible value there in most cases. 

What do you have as your activity id? When you launch the content from Litmos, what's the full URL (including querystring) of that launched content?

Andrew

Chris Cassarino

Hi Andrew,

Thank you for your quick reply!  I am using the auto generated ID shown below:

6MoENRaM6C3_course_id

 

Ashley,

All my launch URL shows is "Story.html" and there is no http or https shown when i open up the publish options.  I am using the Litmos LMS and it does support Tin Can.

 

Ashley Terwilliger-Pollard

Hi Chris,

Sorry for any confusion - I'm referring specifically to once it is uploaded to your web server or LMS. The LMS may generate a different URL - for example SCORM Cloud doesn't give you the option to use the story.html as the accessible link. You'll want to defer to your LMS if you're having difficulty accessing the course once it's uploaded. 

Kevin Thorn

Popping in here....

Andrew, on http://tincanapi.com/content under "Get the activity id right" section, the third bullet reads:

"You don’t have to put anything at this address, it doesn’t need to be the address where the content is hosted; the point is to make sure the id is universally unique."

Per the examples at the bottom of that section, does the activity idea need to begin with an active domain (http://your-org.example.org/ -or- http://content-vender.example.com/) even though the path (activity id) is not live?

Andrew Downes

Hi Kevin, 

The short answer is: no, but you should *own* the domain. 

Let me try to explain the reasoning a little more though so you understand why.

The ideal scenario is that the content creator will host "JSON metadata" at the full URL specified. "JSON metadata" is a computer readable description of the activity that an LRS could go and fetch in order to display the activity name and description in reports or even to a learner. If this definition exists and the LRS fetches it, then it will prefer that definition to the one included in the Tin Can statements. 

An OK scenario, which is what most people do, is to not bother hosting metadata at the URL of the activity id. In this case the LRS will simply use the name and description sent by the Storyline package in Tin Can Statements, or taken from the tincan.xml file. In fact, having an LRS that reads and understands the tincan.xml file is almost as good as the ideal scenario described above. 

The bad scenario is where somebody else hosts a false activity definition at the activity id you defined. For example, I own tincanapi.co.uk so if you set your activity id to http://tincanapi.co.uk/kevins-course I could host some metatdata there which name the activity "kevin smells". Your LRS might then fetch this and display it to your users. To avoid this happening, you should ensure the address used is one you control and that nobody else could host a definition at.

If you don't own a domain, you can register a profile and your activity ids at https://registry.tincanapi.com/

Does that help?

Andrew

Kevin Thorn

Thanks Andrew,

Helps a lot!

What I'm finding is those who publish to TinCanAPI are uploading/publishing to an LMS that does not support or have an LRS. 

If I wanted to build a setup for testing to learn more about how TinCanAPI works with Storyline, should I set up a domain at the address you shared or can I use my own domain (which I control)?  Heh, probably a question for offline, yes? :)

The more appropriate activity name would be "kevin drinks" 

Victoria Sublette

I can't get it to work at all, nor do I understand how it should work.

 

This is the scene:

 

I have read the suggested articles, and what I can understand is the Identifier has to start with https://

 

  • So, that's done. Next, in the launch URL I enter the link to the folder in Litmos where the course resides.
  • I have attached screenshots of my settings as I understand they should be from the posts above.
  • I zipped and uploaded the course to Litmos.
  • I downloaded the Articulate Mobile Player app in the iPad
  • I went to the web and opened the course from our Litmos site using Safari

 

First it indicates that the pop-up is blocked. I go to another tab and it tries to open the course in the Mobile Player, but then gives me a message, "Mobile player cannot access this content"

I am OK with the Mobile player launching the course. What EXACTLY do I need to enter to upload it to Litmos and then have my students access it from the mobile player app on their iPads?

 

Andrew Downes

Hi,

Did you try using story.html as the launch url? 

The activity identifier you've used should technically work, but is not great if you are planning to create more than one course. How about: http://www.teleflex.com/learning/activities/45226-intubation

It's possible that Storyline is adding the http:// bit so also try: www.teleflex.com/learning/activities/45226-intubation as the activity identifier. 

If that still doesn't work, I guess you could try https://teleflex.litmos.com/course/45226/story.html as the launch url with each of the activity ids I suggested above. Try story.html first though.

If none of those work, let us know the exact error message you get with each combination (ideally with screenshots/screen photos) as it sounds like you're now getting a different error than before? 

Also try launching the course from a desktop with each of these combinations. 

Andrew

Victoria Sublette

Nope. Nothing works.

I have tried 4 different scenarios and attached all of the screenshots from my settings and the errors in my LMS.

Scenario 1 (settings attached)

  • Uploads to LMS fine, but in iPad first says, Pop up blocked. Then, allows me to Launch course and then comes up with a message that it is unable to connect to the server (I checked the internet connection and it was fine).
  • The course does get added to the Articulate Mobile library.

Scenario 2 (settings attached)

  • Uploads to LMS fine, but in iPad first says, Pop up blocked.
  • Then a message that Oops! Something seems to have gone wrong. And nothing else.

Scenario 3 (settings attached)

  • Doesn't upload to the LMS - gets a Tin Can Manifest error (image attached)

Scenario 4 (settings attached)

  • Doesn't upload to the LMS - gets a Tin Can Manifest error (image attached)
Victoria Sublette

OK, I finally got it to work!

I got it to work by not using any http or www in the identifier (only victoria123445_course_id), and only having "story.html" in the launch URL.

However, I find the iPad doesn't support using references in captions such as the learner's name (the text misaligns) and sliders don't seem to work.

Anyone know if these are known bugs?

Andrew Downes

Hi Victoria, 

Glad you got this working. I'm worried though that you'll run into problems with that identifier down the line. Does www.teleflex.com/learning/activities/45226-intubation definitely not work? If not, could you send me the package or somehow give me access to give the course a poke so I can figure out what's going wrong?

Thanks!

Andrew 

Ashley Terwilliger-Pollard

Hi Victoria,

I'm glad Andrew was able to assist you here - since the questions seemed specific to your LMS it's typically not something that stay weigh in. 

If you need any other assistance please feel free to let us know, and if you're unsure what elements or areas staff can assist with in the forums or in a case you may want to review our Support policy here. 

fabio fonseca

Andrew / Victoria

Im curious. Im trying to find a solution to run my courses on ipad for a long time. As far as the Articulate support team told me, the AMP is unable to send user id and password to the server.

I can upload my courses to Litmos, that asks for user id and password, but when I run it from Litmos in safari window, the AMP tries to open the course, and I finally got the error msg : "unable to connect to the server".

I can see the screen behing the error msg with the Litmos login window, but I cant access it, and the course never runs on AMP. I attach the picture of the error msg in AMP where you can see the course loaded on background.

If you guys know any possible way to run courses on Artitilate Mobile Player (AMP) under acess control by the LMS, I beg you to tell me.

Andrew Downes

Hi Fabio. 

It's not obvious what the cause of the problem is, so I suggest poking a few different things to see if you can get more information. 

1. Is the IPad connected to the internet? Test this by going to some website. 

2. Is there perhaps some firewall that might block some things? Test this by connecting to the internet via another means e.g. a home internet connection instead of using the company wifi. 

3. Does the course work on the ipad with Tin Can tracking in a browser? You should be able to publish it with the mobile player option unselected. 

4. Does the course work on SCORM Cloud? 

5. Does Litmos support Launching Private Content as described here? https://www.articulate.com/tincanapi/ Test this by uploading all the content to a publicly accessible server and editing the launch url in your publish settings to point to story.html on that public server. You will still need to upload the course zip to Litmos, but if you like you can delete everything in it except tincan.xml. 

Let us know how you get on with each of those 5 things.