References are not appearing in Preview Mode

I have placed a reference to a variable in a text box so I can test that a variable is actually changing from a trigger. When I go to preview mode the text box does not appear at all. I am new to 360 and I know this worked perfectly in Storyline 2.

My parameters are:

 - working on a course converted from 2 to 360

- inserting the reference by creating a text box first and then using the insert 'Reference' option from the Insert menu tab.

5 Replies
Wendy Farmer
William Beardsley

so I can test that a variable is actually changing from a trigger.

Hi William

have you checked that your trigger is not in the wrong order i.e. below a jump to slide trigger so it may not be executing?

Happy to take a look if you want to share the .story file or even just the slides referencing the variable.

William Beardsley

Wendy, I am not even getting that far. the actual text box displaying the reference (i.e. %TestCard%) is not actually visible on the screen at all when you preview the slide it is on. Normally it would display in the initial state of the reference (i.e False) and then when the variable is changed to True by a trigger the text box holding the reference would change from False to True.

William Beardsley

Ok, I've copied the scene that contained this file to  a new project in 360 and now it works. Perhaps there was an inherent problem with the original course that carried over in conversion. I had also been having problems with clicking an item verses tabbing to the same item and pressing Enter - the results were not the same. In the slides I have just copied this now works the same on either click or Enter. Problem seems to be solved but no idea what caused it in the first place.