Resume feature doesn't work after using the Exit course trigger

Hello

I have a simple course published for CD on my computer desktop.

If I close the course by clicking the red X in the top right corner of the app, and then hit "yes" at the Resume prompt, it remembers what slide I was up to.

However, if I close the course by clicking a custom-made button with the "Exit course" trigger, and then hit "yes" at the Resume prompt, it doesn't work, and just sends me to the first slide.

Help?

8 Replies
Ashley Terwilliger-Pollard

Hi Andrew,

The exit course trigger is known to have some issues as detailed here - and I also see a specific issue that has been reported to our QA team regarding the exit course trigger specific to when publishing for CD and not resuming properly. You may want to provide your users with directions to use the browser close button (which is what I assume you mean by the Red x in the corner) instead of the button on the slide.

I have also shared this thread with our QA team as they review the issue so that they're aware it's impacting other users. I'll share any updates I hear from them here, but I can't offer a time frame, so please utilize the workaround mentioned.

Andrew Hooper

Hi Ashley,

Thank you for this. It sounds like the most stable method is to remove the customised exit course button from my master slide, and only allow users to exit by closing the app.

Does this problem also affect web and LMS versions?

Sorry - I'm having trouble with the link you provided. It seems to contain a presentation with only one slide, describing basic navigation features, and the text is in a foreign language!

Ashley Terwilliger-Pollard

Hi Andrew,

Yes, I'd recommend including a note to for your users about how to close the course properly. Maybe at the beginning as a part of the navigation or overview you provide?

Sorry about the link - looks like it pasted in a course I was reviewing from another thread. I've updated it in the original for you. The issue I mentioned is specific to the CD publishing, although if you read the information in the support article now relinked above and included here - it's an issue that occurs based on browser security, LMSs, etc.

Andrew Hooper

Hi Ashley,

I have solved this!

The reason my CD-published course would not resume after using the exit course trigger, is that in a mysterious box, under the LMS publication tab, under Output Options, in the Reporting and Tracking Options window, in a field called LMS Lesson SCORM Information, I had a semi colon ":" in the name of my course.

For some reason this short-circuited the resume feature in both the CD published and LMS versions.

Removing the ":" makes resume work, and it doesn't matter how I publish, or how trainees exit the course.

Sadly it took over a week to figure out. All good

Emalyn Lim

Hi, 

My output is CD and I'm facing the same problem as Andrew when click EXIT it does not prompt resume when I relaunch.

I've tried to check on what Andrew found. Does brackets influence this as well? 

So I removed it and only place text and no symbols or numbers. It is still the same.

P.s. I'm using Storyline's default EXIT button at top right corner. 

Please help!

Leslie McKerchie

Hi Emalyn!

I noticed in another thread, you mentioned you were utilizing Storyline 1 so the information that Ashley shared above still stands and I have no update to provide.

The exit course trigger is known to have some issues as detailed here - and I also see a specific issue that has been reported to our QA team regarding the exit course trigger specific to when publishing for CD and not resuming properly.

You may want to provide your users with directions to use the browser close button instead of the button on your slide.