"Retry Quiz" not working properly when uploaded to Amazon S3

Hi,

I'm using Articulate Storyline 3 and uploads my module in Amazon S3 through Cloudberry Explorer.

I have a 5 item quiz using hotspot and my goal is to grant the users freedom to retry the quiz if they needed to. When I preview my quiz and click "Retry Quiz", everything works fine -- the initial state of each quiz slide resets and you're able to hover and click on the hotspot.

Each of the quiz slides has a "Reset to initial state" setting in the slide properties, under "When revisiting:"

Once I upload it to Amazon S3, when you hit "Retry Quiz", you won't be able to hover your mouse over the hotspots and click on the items, only outside of it. You will need to reset/refresh the Seekbar for it to return to its initial state.

Please advise.

11 Replies
Alyssa Gomez

Hi again Chox!

I took a peek inside your file, and I noticed that the Retry Quiz button on both quiz slides needed a trigger switch. The "Reset Results" trigger should be on top of the "Jump to slide trigger." Otherwise, the results will not have a chance to reset.

I made that change to your file and re-tested it on Tempshare. Could you also test this link and let me know if it's working correctly for you?

Chox Cal

Hi Alyssa,

So, I tried switching the trigger, and when I clicked "Retry Quiz", it didn't go back and doesn't do anything. It just refreshes the result slide but doesn't go back to the quiz. Can you please send me snapshot of the triggers that you modified in my module?

I thought it has something to do with Amazon S3 so I tried it also in Tempshare, but the same issue. Here my trigger: