Retry Quiz - "Score" Reset and "Completion Status" Reset Issue

Dear All,

Please help me rectify the error thrown to LMS from Storyline itself.

When clicking on the "Retry Quiz" button at the Result slide (on Failure), the score is getting incremented internally and thrown to LMS and as a result the completion status is getting "completed" even after not successfully completing the quiz.

When taking the quiz for the 2nd time by pressing "Retry Quiz " button, the score is again becoming 0 but completion status is not getting changed to "incomplete" till the time I reach the Result slide again. More surprisingly, our own certificate is getting generated

Please suggest how can we control the flow of score and completion status after pressing "Retry Quiz" button.

8 Replies
Christine Hendrickson

Hi Rabi,

What LMS are you using? Are you publish for SCORM 1.2, or 2004?

First, you may want to take a look at the articles here and here that may help clear up LMS issues.

If the issue persists, would you mind testing your course in SCORM Cloud to help us determine if the issue is Articulate related or if it's on your LMS's side? If it appears in SCORM Cloud as well, we'd be happy to take a closer look at what might be going on. If you can't replicate the issue in SCORM Cloud, it's probably an issue that you'd want to take to your LMS team. 

Thanks!

RABI SANKAR DAS

Hi Christine,

Thanks for your quick response.

Yes, I published it as SCORM 1.2 and I am testing my course in SCORM Cloud as well as in some other Test Suites like ADL. The issue is same in SCORM Cloud and in other test suites.

When we are clicking on Retry Quiz button, completion status is getting "completed" even after scoring less than 80% which is our pass score.


Thanks and Regards,

Christine Hendrickson

Hi Rabi,

I sincerely apologize for the delay. I have submitted a support case on your behalf (#00319345) so our technical support staff can take a look at the file and test it. I've added the file to the case and linked to this thread, so our team can see what steps you've already taken to troubleshoot the issue. I'll be following the progress of the case and I'll share any updates on the case. 

Please keep an eye on your email, one of our support team members will be contacting you soon. 

Thanks Rabi,

Christine

Christine Hendrickson

Hi Steven,

It looks like Jonathan, one of our support engineers, was not able to reproduce the issue in SCORM Cloud. I don't see any other responses from Rabi in the support case.

If you're experiencing the same issue(s), please refer to my earlier post.

If you wind up empty-handed after reviewing the links above, I would next recommend comparing the performance of your content at SCORM Cloud. If you cannot reproduce the problem there, this is likely an LMS-specific issue, and you will want to generate debug logs and supply them to your LMS Provider for additional troubleshooting.

Thanks!