Screen Recording playback not smooth - page loading visible

Recorded screen. Inserted as "Step-by-step slides", everything fine but when I preview it, every time it goes to the next slide, for a split second, one can see the page loading "action" (modern view, screen grays and 3 dots go across page - see simulated screen shot attached; or classic view, spinning wheel). This "kills" the fluidity of the screen capture. Is this the nature of the step-by-step mode, poor processing speed of my laptop, something else? I can do single slide screen recording but then must guess on timeline when screen changes. Thoughts? Thx 

13 Replies
Crystal Horn

Hi there, Bill!  I'm sorry you're seeing some laggy loading with your slides.  I mocked up a quick example just to see what happened on my end -- you can check it out here.  My transitions seemed smooth between the step-by-step View mode slides.

Can you share your .story project here as an attachment?  I'd hate to miss something by just chalking it up to "computer processing" issues without having a good look first.  Thanks!

Bill McKee

Crystal, attached is my .story project. Also I captured your screen recording with PEEK from my PC and you can see some lags -- check it out here. Thanks for taking a look.

p.s. After working over an hour w/ Replay this afternoon I noticed the playhead wasn't tracking with the screen and/or lower thirds titles, so could be memory issues? 

Any feedback helpful.

Ashley Terwilliger

Hi Bill,

Thanks for sharing your file here and that Peek. I took a look and noticed that it was appearing normally for me in Preview and once published to Review. You can view my version here. I didn't see the loading screen that you showed at all - so if you still see that in Review it could be a memory issue or your Internet connection also. My speed today is pretty fast (around 105 Mbps), and I was using the latest version of Chrome on Windows to view the course. Have you checked your internet speed? You could use this site to check it - http://www.speedtest.net

If you think it's a memory issue with your computer, you could try my link while all other applications and programs are shut down to see if there is a better playback there. Since you also see the slowness while editing in Replay, it's worth double-checking that you're on the latest update of Articulate 360 (Update 17) as we did have a memory leak that is fixed in a recent update. 

If the internet speed is good, and it's still slow, let's have you work with our Support Engineers to dig into the memory issues. 

Bill McKee

Ashley, sent this response by selecting the reply button in the email I received but it didn't show up in thread so didn't know if you got it. So I'll post here directly.

Taking your feedback, I tried something different to see if it was my PC, internet connection or a software anomaly. I created a screen recording of the exact same steps using Storyline 360 and  Captivate 9. I then played them back and captured the playback using Replay and published the results on my Review Page. You can check them out here:

ScreenRecord_Storyline and ScreenRecord_Captivate

You will be able to see the difference. I do not remember it being this way with SL2 but then the page/slide loading isn't as noticeable with the classic player. We would like to do more screen recordings and like the fact that we can embed SL content in Rise, but this could be a stumbling block. Any direction you or other can provide would be much appreciated. Thank you

Katie Riggio

Thanks for working through this oddity with us, Bill! 

To add to the testing collection, I published your project to Web using the latest version of Storyline 360–here's my output and a peek of what I saw in Chrome 68. I saw the expected three dots, preloading behavior with the Modern Player, but I didn't see them during the slide transitions. 

Sorry for the back and forth, but can I confirm which browser(s) you come across this issue in as well as your Storyline 360 version? Last few questions before we delve into how to solve this, I promise. ☺️

Bill McKee

No worries. FYI, when I selected the reply button in your previous email instead of taking me to discussions it opens up a new email in Outlook addressed to 'reply-538773@heroes-prod-reply.articulate.com'. It obviously did not reach you. On to the discussion at hand:

First, answers to your questions:

  • Storyline 360 version: 3.18.16333.0 (although I just updated and when I created the .story in question it might have be the previous version)
  • Chrome version: 68.0.344.84

Now the weird part:

Here is my peek recording of the Storyline 360 output link you sent me. Notice that it shows the “three dots” during transitions where your recording of this same output did not.

The first time I viewed your Storyline output (not your peek) I only saw the three dots once or twice between transitions during playback. The second time I watched it, the number of times I saw the three dots during transitions increased. My peek recording was the fourth time I viewed the recording. The three dots seem to appear at almost every transition.

To validate I sent the link of your output to my colleague to see it she might have a different result. Upon selecting the link, the “Resume/Restart” screen appeared. She selected Restart and watched for the recording for the first time on her PC. The three dots appeared as many times as they did in my peek video.

SIDE NOTE: She had previously created a Storyline 360 screen recording in which we didn’t see the three dots initially during slide transitions but after a few plays we did.

At the outset it appears that some degradation occurs over the number of times played but not sure it that is true in your environment (i.e. if you ran the recording three of four times back to back you would experience the same result?) If that is not the case then I am open to any ideas or thoughts you have on this conundrum. Don’t mind the back and forth.

Thank you.

Katie Riggio

Thanks, Bill! That certainly is strange, as the specific reply address looks correct–I wonder if something in your email settings is flagging it as an odd email? I've shared this with my team and will keep you posted if we find the culprit!

Digging in: really appreciate you sharing your testing details–super helpful! I played my previous output link five times in Chrome (68.0.3440.84) where I'm still unable to reproduce the three dots seen during the slide transitions–here's a Peek of the retest. Are you and your colleague viewing this under the same network? I'd be curious to know if this happens if you test it on a different connection.

In the meantime, I'd like to get our Support Engineers' opinion on this conundrum (indeed!) and have created a case on your behalf with my notes attached. Someone from the team will be in touch shortly; I'lll follow along as I'm itching to know what's causing this! Thanks again for working with us!

Katie Riggio

Hey, Bill! Circling back to share our findings in case others run into this issue.

After rigorous testing, my teammate, Joshua, logged step-by-step slides display the loading bar between each step when using HTML5 output as a possible bug.

We’ll share updates here and in your case once we have them! Thanks again for your hand in testing and for working through this one with us ..give us a shout if you need anything else!