Slide Navigation not Working

Hi. I noticed after Update 3 that slide navigation no longer works as it used to. For example, clicking the Previous button causes slides to very briefly (for like half a second) return to the previous slide, and then bounce back to the slide I was on. This same behavior occurs when I have a user return to a slide they previously covered for review purposes, that is, it bounces them right back to the slide they were on when they clicked the navigation button that jumps them to a previous slide.

Is there some new default behavious I need to change now? How can I fix this?

8 Replies
david mckisick

Just to add a bit of data to this issue, I have triggers set to jump to next slide when timeline ends for most of my slides. I have the UI prev/next buttons disabled and use custom prev/next buttons on the slides I want to use them on. Slide properties are set to Slide Advances: By User, and When revisiting: Automatically decide.

It looks to me that the new behavior after Update 3 is to pick the previous slide up as being at the end of its timeline and so it seems to be automatically jumping to the next slide right away, instead of playing through the content like it did before Update 3. Any help very much appreciated.

Christine Hendrickson

Hi David,

If the slides are set to jump when the timeline ends, it might be best to try changing the revisiting settings to "Reset to initial state". That, or you could apply some conditions to the slide and the advancement options.

I don't see what the update applied that would actually make this change, so it sounds a bit odd that it's only behaving this way now. 

Can you try the suggestion above and let me know if it resolves the problem?

Thanks!

david mckisick

Hi Christine!

When I set the slide to "reset to initial state", it does indeed work. However, I have a variable set to change to True when that slide finishes its timeline. Idea is that if someone revisits this slide for review purposes, that they can then zip on back to the slide they came from with one click. If I set this slide to reset to initial state, would that screw up my variable as well?

david mckisick

Allrighty. Lots of time spent on this. To get it to work properly I first had to get rid of the trigger to advance the slide when timeline ends. Navigation will no longer work properly if you have this trigger set for some reason.  I set the variable to change state to True when user clicks the Next button, which I had to add because the slide will no longer automatically advance.

Christine Hendrickson

Hi David,

For your first question - I don't believe so, no. It shouldn't reset the variable, just the slide. 

I've seen a lot of courses that had this type of issue with using anything other than "Reset to initial state", prior to Update 3. That doesn't mean they were exactly the same - but that's why that was one of the first questions I asked :) 

I am sorry you've had to spend so much time on this. In theory, it should work with a variable, like the one you mentioned. 

How about adjusting a variable on the next slide instead, when the timeline starts? This seems to work very well, even with the revisiting settings you prefer to use.

Hopefully that'll be an option for you to try :)

Thanks!