Slider variable-to-layer issue

Sep 17, 2020

Hi! I need help, please! Can an Articulate staff person or a Storyline user who is knowledgeable about sliders please check out my attached file and let me know what I'm doing wrong?

This is the second of two slider interactions in my course (the first one has been removed from this pared down file). The Correct layer is supposed to display when the slider is moved to the gray dashed line (SliderA variable = 3), but the Incorrect layer displays instead, for all of the slider arrow's positions.

I've spent the last two hours troubleshooting this issue, and I cannot figure out why it's not working correctly. It's built no differently from the first slider interaction, except that the slider arrow starts at the far right in this one, instead of the far left, so the variable count is backwards. That shouldn't matter, though. The slider properties allow flexibility regarding where the variable/arrow starts out and where the end is, and the step increments to get there. A reference for the Slider A variable is included, so you can see in Preview or 360 Review how the variable changes as you move it. 

Thank you in advance for your help! 


3 Replies
Tom Kuhlmann

Not sure what happened, but I think the hover state is doing something with the trigger. 

I created a new button from scratch and it worked. I looked at your submit button and obviously it didn't. I noticed the hover state had different sized text, so I removed the hover state and it worked.

I tested the font on my button and it works to resize t, so maybe there was just something on your button that was corrupt. In either case, I'd just rebuild the button and it seems to work fine.

Video proof :)


Lisa Spirko

Hi Tom and Walt! Thank you both so much for your help!

I tried fixing the trigger first, as that seemed to be the more likely culprit than the hover state on the Submit button. (The text on the hover state on the Submit was intended to be a little bigger.)

Addressing the triggers fixed the issue, but I had to recreate both of the triggers for incorrect and correct feedback from scratch. The issue persisted when I copied the trigger that was working (for incorrect feedback) and altered it for the correct one, and recreating just the faulty one didn't work, either. I had to recreate both from scratch. (Tom: This is why your blue button worked... first, you tried copying the triggers, and that didn't work, but it worked great when you recreated the triggers from scratch.) It seems that triggers can get corrupted when they're copied and tweaked, and this is something I do a lot, so I think I probably need to get out of the habit of doing that as much as I do. (Always looking for the fastest way to do things, lol!) 

I also took both of your advice about using the < sign instead of spelling out each value with an OR. That didn't fix the issue, per se, but it certainly simplified the trigger! 

Thank you both again for looking at this and offering advice! I really appreciate it! Have a great Weekend Eve and Weekend! :)


This discussion is closed. You can start a new discussion or contact Articulate Support.