Slides navigating in the wrong order

I have a new one! At least I can't find any discussion of this.

I hope I can explain this so you can follow it.

Slide 1.1 forward arrow goes to 1.2

Now on 1.2, the back arrow goes to 1.1.

Forward arrow again and it goes to 1.2 (so far so good). Forward arrow again and it goes to 2.1 (as it should). 

Back arrow from 2.1 goes to 1.2. All good.

Back arrow again from 1.2 and it goes to 2.1. WHAT?!

Back arrow toggles between 1.2 and 2.1, never getting back to 1.1

(I can move forward, it's only the back arrow that's screwy)

This happens at some other places within the storyline.

Everywhere I search for support tells me about the menu.  I don't care about the menu, I'm not showing it anyway. I just want the forward and back arrows to work like I expect them to!

I don't know if this is related, but my scenes aren't all in order. For example, in the situation above, it's actually 3.1, not 2.1 because scene 2 has lightbox slides. So the last slide of each scene is manually set for the "next" button (i.e., 1.2 next is set to go to 3.1) and the "back" button on the first slide of each scene is manually set to go to the last slide of what should be the previous scene (i.e., 3.1 is set to go to 1.2 when the back arrow is clicked). I don't think this is causing the problem, though, as the arrows only go to the wrong place once I try to back up more than one slide, and the problem doesn't always show up when changing scenes.

If there's a better way to reorder scenes so I can just say "next slide" or "previous slide" and just skip over scene 2, I'd love to know it. But mostly I just want to be able to back up more than one slide without a problem!

10 Replies
Alyssa Gomez

Hi Beth!

Is the previous button triggered to jump to a particular slide, or is it triggered to jump to the "previous slide?"

If the button is triggered to jump to the "previous" slide, it'll go to the last slide you visited. This is similar behavior to a web browser's "back" button.

However, it sounds like you're stuck in a loop between two slides, and that definitely shouldn't happen. 

To get a better idea of what you're seeing, I'd love to take a closer look at your file. You can share it publicly here, or send it to me privately by uploading it here. I'll delete it when I'm done troubleshooting.

Piotr Burchart

Hi All,
I have noticed exactly the same problem with my module, but not on every slide, only between slide 2 and 3 (during the first slide visit (2) player previous button works fine, when I navigated to the slide 3 and back to slide 2, the previous button navigated to the slide 3 instead 2). I have about 50 slides and only problem was on slide 2. So, the question is why only this particular slide? Have used the slide number instead and working fine.

Thanks for confirmation that this is a common problem/issue.

PB

Crystal Horn

Hi there, PB.  It's hard to say why only slides 2 and 3 were behaving this way without seeing your file.  Would you be able to share the original version of your project?  If so, you can share it publicly here, or send it to me privately by uploading it here.  I'll delete it when I'm done troubleshooting. 

I'm glad that using the trigger to jump to slide X is working the way you'd like, in the meantime!

Crystal Horn

Hi again, Peter!  I emailed you back specifically about your file.  I was seeing a couple of slides that identified specific slides for the Previous button, and a couple of slides that used the "previous slide" default.  The looping was happening because of that setup.

Feel free to reply to my email with specific questions!

Piotr Burchart

Hi Crystal,

Thank you for your quick respond. 

In my understanding the previous button will only back us to the previous slide if we have slides put in order: 1.1, 1.2, 1.3, 1.4 etc.

If we will broken the above order by using one of our slide like a full size pop-up (with extra exit button), then we can experience the above problem.

Thank you so much for clarifying this for me. After years I know finally why I had a problem with the previous buttons placed on the master slide (fixed by using specific slide number: back to X, Y, Z)

KR,

Piotr

 

Crystal Horn

Hi Piotr.  Almost.  ☺️

The previous button using "jump to previous slide" will work as long as all of the slides are set up this way.  Because some slides were using "jump to slide X," like slide 1.6 in your project, it lost the history of the previous slides.  

In your project, you can either always use the default "jump to previous slide," or always change all of the triggers to "jump to slide X."