Storyline 2 and Google Doc Form

Nov 29, 2016

I've seen some previous discussions surrounding the Google docs and how to insert them into Storyline. I am able to embed the Google Form into the slide using the insert video from web, but when I publish it to test it, I am not able to enter anything into the form or hit the submit button. I am able to scroll down through the page/form, though. I've seen some of the older published examples, but that was also an older version of Google Form. Any ideas?

23 Replies
Ashley Terwilliger-Pollard

Hi Jennifer,

Are you inserting it as a web object or as a video? The latter wouldn't be interactive. 

You'll want to insert as a web object and then ensure that the Google form is set up to allow submissions as well. If you've set that up correctly and are still having difficulty are you able to share a copy of your .story file here so that we can see how it was set up and view the embed code you're using? 

Jennifer Velazquez

Hi Ashley, 

Thank you for your response. I was actually using the insert video feature because that made it possible for me to embed the form within the slides and not pop out into a new browser. When I tried to plug in the embed code into the insert web object, the web address was considered invalid. Here is the embed code Google form provided:  

<iframe src="" width="760" height="500" frameborder="0" marginheight="0" marginwidth="0">Loading...</iframe>

Russell Killips

Here's another approach. This time I didn't create a web object. I still used the Web Object tool in Storyline. For the Address of the web object,  I entered in the src address of the iframe.

Here is a link to view on our company website.


Ashley Terwilliger-Pollard
Leslie McKerchie

Hi Jennifer! What difficulty are you having with Russell's file? I took a look, published, and it seems to be working for me.

Hi Jennifer,

Did you test out the link Leslie shared above? That one worked for me in Chrome (latest version) on a Mac. If you're not able to use that one, please let us know what browser you're using as well as perhaps that is a part of the issue with how you're viewing/testing the course. 

Leslie McKerchie

Hi Jennifer!

Please be sure that you are zipping and uploading the content, then viewing in that environment as a learner would. Viewing locally can still cause issues as you can see here.

You could test uploading/viewing to Tempshare as well if you'd like and perhaps that would indicate an issue with your web server vs the content.

Martin Lemieux

Hi All, 

I'm experiencing a challenge with a web object that I inserted into my course.

It's strange because I have other courses where I did the exact same thing and it is working fine.  But for some reason in this course, the web object is not working.

The web object is linking out to a particular google form

I have the web object set up as follows:

But, when I go to test the link, I get the following message:

What's that all about?  I don't understand why it is working in one course and not in another, when I've literally just cut and pasted the entire slide from course to course, and then just substituted the form's URL. 

Can anyone shed some light on this?



Alyssa Gomez

Hi there Martin! Just to clarify, you're seeing this behavior in the published output of the course, correct? You'll want to make sure that you're viewing your content in the environment in which it'll be used. 

Also wanted to point out that some websites (like Google) are intentionally prevented from displaying inside an iFrame. Have you tried the option, 'Display in a new browser window'?

ff ff

Hi there, 

This is an old thread, I know. This is my first day into storyline, using the 30 day trial so far and I am very happy about it! (it works so much better than Captivate, I was able to create the project I was planning in under 2 hours, while in captivate I lost two days just to get a button working - or better trying to, so kudos!)


I tried to attach a Google Form as a mean to collect contact data from the customers.

The project works just fine, however the form will not load - I just get a white picture. This happens in Preview mode as well as after publishing it. Also, in Tempshare. Cannot seem to find a solution to this on google as well.

Edit: Neither "Display in slide" or "Display in Browser" works. Just the white slide.

I have attached the zip of my project. Please keep in mind that only the "Kontakt" button in the second slide is connected so far.

Appriciate the help!


Alyssa Gomez

Hi there!

Welcome to the community, and I'm so glad to hear you're enjoying Storyline. We love it too! 💙

I also tested your zipped file in Tempshare, and I saw a blank screen where the Google Form should be. Would you mind sending me the link to the form you're trying to embed? I'd like to try it in a new Storyline file.

By the way, what version of Storyline are you using?

ff ff



I just realized the smallest thing, and now it works - this is so obvious that I didn't see it, but I want to share here so that other people with the same problem will find an answer quick.


Always - and I mean always - check your timeline. When you add something to your project, it will be added right where your indicator on the timeline is. Same here - it was all the way back, so the form wasn't loaded YET. I changed the inpoint to the beginning of the slide, and now it gets loaded fine and it works!

Sometimes, you need to take a step back to see clearly :D


Now I only need to figure out a beautiful way to get the people back to the project when the form has finished sending. I do not have the built-in player, after all (it was a design choice)


Thanks for the help anyhow!

- Flo

This discussion is closed. You can start a new discussion or contact Articulate Support.