Storyline 2 Course Upgrade Quiz Error on LMS

Hey everyone, I thought I'd share some issues I am experiencing with Storyline 2 to see if any of you are sharing in my pain and have a possible solution:

I noticed that when I upgrade a course from Storyline 1 into Storyline 2 and publish that course to my LMS (Oracle product), I find that the quiz/test within the course returns a "405" error every time a question is answered (correct or incorrect). If I go back and upload the original Storyline 1 file, I do not get this error. If I build a course from scratch using Storyline 2, I also do not get this error. I tried deleting the quiz from the upgraded file and rebuilt it but resulted in the same error. I just have a standard quiz: true/false questions, multiple choice, and multiple selection.

Articulate support has looked at my files and experienced the same thing, but have no solution as of now.  So, I'm having to go back to my Storyline 1 files and update/publish them through there.

3 Replies
Rachel McGregor

Did you find a solution Ken I am having a simalr problem. See extract from debug report below.

To try to get round this I set the pass score to 0% as we were using the quiz for knowledge and skill building rather than testing. I didn't bothe changing the points for each quiz slide. Sometimes it tracks and completes other times it does not show completion.

HELP!

ERROR = 405
Incorrect Data Type - Invalid Type being used for setting element - the type being used as the set value argument does not match that of the element being set
API Function : LMSGetLastError( )
API Function : LMSGetErrorString( '405' )
API Function : LMSGetDiagnostic( )
API Function : LMSGetLastError( )
API Function : LMSSetValue( 'cmi.core.score.raw', '81.81' )
API Function : LMSSetValue( 'cmi.core.score.max', '100' )
API Function : LMSSetValue( 'cmi.core.score.min', '0' )
API Function : LMSSetValue( 'cmi.core.session_time', '0000:08:48.96' )

 

Leslie McKerchie

Hi Rachel!

I was able to track down Kenneth's case (00665045) and it looks like he reached out this morning as well to follow up on the issue.

The issue reported is still in the hands of our QA Team and I do not have an update to provide at this time.

I will add this thread for user awareness and so that we can provide an update when applicable.