Storyline 2 - layers, problem with HTML5

Dear all,

I have a slide with some buttons. When a button is clicked, a layer opens with a question. In the properties of the layer, I ask that the user cannot click items in the basic slide. This is quite basic. The problem is that when I publish it, the HTML version and the offsite version through the viewer work great BUT the HTML5 version does not work and it still allows the user to click on the basic layer (so the user can select a new question, before the opened one is answered). I use the latest update of storyline 2 (May 2017). Any suggestions on what I could do? This seems to me a very basic issue in the use of layers.

If you wish, you can see the example on line. In the first screen you must select the option: 'with a friend (two players)'. The problem is in slide 3 (with the squares and the questions). Select any square to open a question.

HTML version that works fine: http://vbouki.com/st/ttt/story.html (if a question is open the user has to answer it before s/he can click on another question) 

HTML5 version where layers do not work: http://vbouki.com/st/ttt/story_html5.html (if a question is open the user can click and select another question without answering the open one).

Many thanks,

Vassiliki

 

13 Replies
Alyssa Gomez

Hi Vassiliki,

Thanks for including the links to your published files! I tested the HTML (Flash) version, and I was able to open all of the questions without answering them. 

Here's a sample file I created with Storyline 2. In the layer properties, I selected "Prevent the user from clicking on the base layer."

Do you have that setting selected on your slide layers?

Vassiliki Bouki

Hi Alyssa,

Thanks for the reply and your time.

I do have checked the 'prevent the user for clicking on the base layer' - it is a very basic  thing. I'm surprised you write that even the HTML version does not work. I have checked it from windows and mac environment and it works fine. It is only the HTML5 version that does not work. Are you sure you tried the story.html version because sometimes, it changes automatically to story_html5.html - it happened to me in windows environment (never in mac) and I had to type the address. In any case, thanks for your time. As this is a very basic property of layers, it is very bad that HTML5 does not work.

Vassiliki

Vassiliki Bouki

Hi again Alyssa,

Could you please let me know in which operating system and browser you tried the story.html file and it does not work? I tried it in IE, firefox, chrome, safari (in windows and mac) and it works fine. It is only in the Opera browser that the version changes automatically to the 'story_html5.html' file that does not work. Apparently, because it changes automatically, I cannot test the story.html file in Opera.

Many thanks,

Vassiliki

 

Alyssa Gomez

Hello Vassiliki,

Sorry for the confusion! I tested the story.html link in Chrome v58, Internet Explorer 11, and Firefox 53. 

Would it be possible for you to share the original .story file with me? I'd like to take a closer look. You can attach it here in the thread, or if you'd like to keep it private, use this form instead.

 

Alyssa Gomez

Hi Vassiliki, I have an update for you! We're tackling an issue in Storyline 2 HTML5 where the setting "Prevent the user from clicking on the base layer" will not work if "Hide other slide layers" is also enabled in the layer properties and if this layer is called by another layer. This matches exactly what I'm seeing in your file.

As a workaround, try covering the tic-tac-tie buttons with a hotspot or transparent shape on each layer to prevent learners from clicking them before they answer the questions. 

I'll be sure to let you know as soon as I have an update on this issue, and I apologize if it's been giving you headaches!

Vassiliki Bouki

Dear Alyssa,

Many thanks for the update. The 'hotspot' suggestion is a solution.  Just one remark in your message: you identified 2 conditions "if "Hide other slide layers" is also enabled in the layer properties and if this layer is called by another layer." In my file, the first one ('hide other slide layers') is correct but the second condition  (this layer is called by another layer) does not apply. The question layer is called from the base layer (slide).

Many thanks for your time,

Vassiliki 

Alyssa Gomez

Hi Vassiliki,

This bug seems to happen as soon as the first "feedback correct" or "feedback incorrect" layer opens. Those layers have "Hide other slide layers" enabled in the layer properties, and they are called by another layer. Here's a quick Peek at how that affects your file. 

In any case, I'm glad the hotspot suggestion will work for you. I'll be sure to post an update here as soon as I have more information!

Vassiliki Bouki

Dear Alyssa,

Thank you so much for your time to do the screen recording.

Just one remark if you follow the other option (the first button (two players)) the problem starts even before another layer (feedback) opens. I just mention it, in case it would be useful for debugging.  In the 'two players' option, after the first slide I run a question bank with two slides in order to randomise who plays first, then I ask the names of the players and then the game is similar to what you had in the screen recording, with the only difference that players have turns.

Many thanks again for all your help.

Vassiliki

Alyssa Gomez

Hi Vassiliki,

Thanks for checking in! I don't have an update at this time, but I will certainly notify you as soon as I get new information.

I upgraded the file you sent to Storyline 3 and Storyline 360, and the issue isn't happening there. It looks like this is only happening in Storyline 2. 

Thanks for sticking with us on this--we'll let you know as much as we can, as soon as we can!