Storyline crashes on preview or publish

Mar 28, 2017

every time I try to preview or publish a certain .story, Storyline crashes and I get an error report:

<?xml version="1.0" encoding="utf-16"?>
<ErrorReport xmlns:xsi="" xmlns:xsd="">
<FirstName />
<LastName />
<Message>TimeSpan does not accept floating point Not-a-Number values.</Message>
<StackTrace> at System.TimeSpan.Interval(Double value, Int32 scale)
at gf.g()
at gf..ctor(Shape A_0)
at Articulate.Design.Shape.AddPlayerEventsCore(IPlayerService service, IPlayerTimeline timeLine, bwStageObject stageObj)
at Articulate.Design.Shape.Articulate.Player.IPlayerShape.AddPlayerEvents(IPlayerService service, IPlayerTimeline timeLine, bwStageObject stageObj)
at Articulate.Player.PlayerContentPublisher.a(IEnumerable`1 A_0, bwSlideBase A_1)
at Articulate.Player.PlayerContentPublisher.CreateSlideObject(IPlayerSlide slide, bwISlideContainer sceneobj)
at Articulate.Player.PlayerContentPublisher.CreateBridgewaterSlide(PlayerWriterSettings settings, IPlayerSlide slide, bwISlideContainer sceneobj)
at Articulate.Player.PlayerContentPublisher.CreateContentScenes(PlayerWriterSettings settings, IPlayerContentProvider contentProvider)
at Articulate.Player.PlayerWriter.WriteContent(IPlayerContentProvider contentProvider, Nullable`1 merged)
at Articulate.Player.PlayerWriter.Write(IPlayerContentProvider contentProvider)
at Articulate.Design.Publish.TargetContext.PublishBackgroundWorker.OnDoWork(DoWorkEventArgs e)
at Articulate.ComponentModel.STABackgroundWorker.a(Object A_0)</StackTrace>

any idea on how to fix? thanks, Steve.

22 Replies
Alyssa Gomez

Yikes! That's definitely not supposed to happen, so let's see if we can straighten this out. Since you said that this happens only with a certain file, we can assume it's not an issue with your software but rather with the file itself. Would you mind sending your file to our support engineers here so we can test it? 

Katie Riggio

Sorry you're also at this roadblock, Monica. Happy to help!

Looking at Steve's case: My teammate, Miker, found a corrupt object on a slide that caused Storyline's crash. Do you experience this problem on a specific slide or with multiple ones?

Let us know how the importing process goes! If you're still stuck, we're ready to help! 

Monica Jackson


Thanks for the suggestions. I imported the SL file into a new SL file. I have four scenes and less than 20 slides. I was able to preview the first scene. Upon attempting to preview the second scene, SL crashed. I'm going to attempt to preview each slide in that scene, to determine if I can isolate the problematic slide. Hopefully, it won't be too painstaking and I can recreate the slide that is "giving me the blues" :-). Thanks again!

Katie Riggio

Thanks for the update, Monica!

It sounds like there's a corrupt object in the second scene. You can identify it by deleting objects one by one until you find the culprit.

It can be a laborious process – especially when there are a lot of slides – so don't hesitate to reach out to us for help! With your permission, we'll help you troubleshoot your .story file and will delete it once we nail down that culprit. 

Monica Jackson

Yes, that is what I did. The problem was a table on a slide in the second scene. So, I deleted and recreated. It wasn't too painful to locate. I just needed to know where to start to locate the issue. The first approach was to try to preview each scene. If the scene did not preview, then I knew the problem was in a particular scene. Thankfully, it was only one slide and one object.

Thanks again!


<?xml version="1.0" encoding="utf-16"?>
<ErrorReport xmlns:xsi="" xmlns:xsd="">
<Message>Specified argument was out of the range of valid values.
Parameter name: direction</Message>
<StackTrace> at PointF s.e(IAnimatable A_0, Direction A_1, bool A_2, int A_3)
at bwVarPoint s.g(IAnimatable A_0, Direction A_1, bool A_2, int A_3)
at bwVarPoint af.e(IAnimatable A_0)
at bwPositionSegment af.g(IAnimatable A_0)
at bwPositionSegment af.h(IAnimatable A_0, Direction A_1)
at bwTweenPosition af.u(IAnimatable A_0)
at bwAnimation af.s(IAnimatable A_0)
at void u.Animate(IAnimatable animatable)
at string Articulate.Design.Animations.ShapeAnimations.a(bwStageObject A_0, string A_1, Nullable&lt;TimeSpan&gt; A_2)
at void A_0)
at void Articulate.Design.Shape.Articulate.Player.IPlayerShape.AddAnimations(IPlayerService service, bwStageObject stageObj)
at void Articulate.Player.PlayerContentPublisher.a(IEnumerable&lt;IPlayerShape&gt; A_0, bwSlideBase A_1)
at bwSlide Articulate.Player.PlayerContentPublisher.CreateSlideObject(IPlayerSlide slide, bwISlideContainer sceneobj)
at void Articulate.Player.PlayerContentPublisher.CreateBridgewaterSlide(PlayerWriterSettings settings, IPlayerSlide slide, bwISlideContainer sceneobj)
at bool Articulate.Player.PlayerContentPublisher.CreateContentScenes(PlayerWriterSettings settings, IPlayerContentProvider contentProvider)
at bwContent Articulate.Player.PlayerWriter.WriteContent(IPlayerContentProvider contentProvider)
at bool Articulate.Player.PlayerWriter.Write(IPlayerContentProvider contentProvider)
at void nr.n()
at void Articulate.Design.Publish.TargetContext+PublishBackgroundWorker.OnDoWork(DoWorkEventArgs e)
at void Articulate.ComponentModel.STABackgroundWorker.a(object A_0)</StackTrace>


Even after importing to different SL files, this still comes up. This seems like a commonly occuring problem.

Vincent Scoma

Hey Brian,

I am sorry that you are hitting this snag!

Does this issue seem to happen with one specific course? If so,  with your permission, I'd like to take a look at your project file to investigate what's happening. You can share it publicly here, or share it privately with our Support Engineers here. Either way, we'll let you know our findings and will delete it after having a closer look!

Becca Levan

Hello Chris, and welcome to E-Learning Heroes! ⭐️

Sorry to hear you're hitting this snag, and I"m happy you reached out! It sounds like this is happening with one specific project? If so, I'd recommend sharing your file with one of our support engineers to help troubleshoot. Feel free to reach out here, and someone from my team will be happy to help get to the bottom of this!

Kason Damien

Sorry to dig up this case again - but just wanted to share with all the other e-learning heroes of my experience with an error when trying to publish my .story file. I've been on Google for the last 2 hours trying to figure out what went wrong on my own as the Live Chat feature is only available Mon - Fri and I wasn't able to create a support ticket because there was an error trying to upload the .story file. 

- So I came across multiple threads with people facing the same issue, so I did try various methods from saving the file locally to renaming the files etc.

- I opened a new Storyline file, and imported scene by scene and tried to click on Publish until I was able encounter the same error.

- What i did next was to import the scene slide by slide until I hit the same error message again and relooked at what was wrong with the slide.

- I found out that a navigation button was the one causing the issue. I deleted it, created it again and was able to publish the file with no issues.

Although it is a tedious process especially if you are working with hundreds of slides, this is the only troubleshooting method that works for me - especially on a weekend.


Hope this helps someone out there who is facing the same issue too. 

John Morgan
Hi Ben!
I appreciate you sharing that you are experiencing crashing during preview and publish. I’m happy to help you with this. It sounds like you are confirming that you are unable to preview the entire project. Here are some steps to help you narrow down where the issue may be happening:
  • Can you preview individual scenes (if applicable)?
  • Can you preview each slide in the scene identified?
  • When you identify specific slides, hide objects until you can locate the culprit.
If you’d rather work directly with our team, please share your project file privately with our support engineers to investigate what’s happening with your permission. It will be deleted when troubleshooting is complete.
Thanks for reaching out!
David Waldron

I narrowed it down to which slide it was, and saw it had several layers and it would take a while to go through each object.

I changed all fonts to Arial using Find and Replace Fonts, and it worked. Hope that helps someone! 

(I'm not sure which font was the problem font but I replaced: Calibri, Open Sans, Roboto, Roboto Slab, Segoe UI, Tahoma, Wingdings. I kept Arial and Arial Black as the only two remaining fonts).

Jose Tansengco

Hello Stephanie, 

Sorry to hear that you ran into this behavior. 

There's actually a chance that any publishing or previewing issues that you're experiencing might not be related to fonts at all! Would you be willing to share a copy of your project file here or in private by opening a support case so we can take a closer look at what's happening with your file? We'll delete it when we're done testing!