Storyline2 - Text entry interactions - focus on slide timeline start

Jul 26, 2015


I've got a series of simulations which include multiple text entry fields/interactions.

Is there anyway of ensuring that when the slide first loads that the focus is on the text entry field automatically i.e. the text can be entered without the user having to complete the additional step of clicking into the field (which has already been done as the preceding action) - there is the option to 'merge' the steps but this would create quite a lot of additional work across 3 playback modes so am hopeful there is an alternative approach...

Any help much appreciated.



26 Replies
Leslie McKerchie

Thanks Greg!

Are you utilizing the latest update to your software?

You may find that a data-entry field doesn't have focus when you visit a slide in your published output. As a result, you have to click the data-entry field before you can begin typing in it.

This issue was corrected in Update 5 for Articulate Storyline 2. 

Sanjay Sanichara

Just for anyone looking a solution to this potentially frustrating issue...there are a few things I did to make sure that when any of my pages with text entry fields loaded, the cursor in the text entry field was in focus. 

1. Make sure that the text entry item on your timeline (e.g. Text Entry 1) is the first thing at the bottom of your timeline. 

2. If you have any background images on your timeline (e.g. screenshot of the software you are developing training for), put that image on a masterslide layout, delete the actual image from the slide itself, and use the masterslide layout with the image on it instead.

3. Finally, Alt text. Make sure no other items on the screen are "visibile to accessibility tools". Only the text entry field should be visible to accessibility tools (including any objects on the master slide).

In my experience, these 3 things have solved this issue for me. Hopefully it works for you and saves you a lot of time and frustration!



Maria Campos

Hi Leslie,

So it means that this bug wasn't fixed in a previous update after all right?

In a step-by-step test with screen recording when splitting into slides it didn't split the one with text input. I copied the previous slide, adjusted the timeline and added a data entry field but it just doesn't focus when I preview.

Already changed tab order and timeline. The field cannot be the first at the bottom or it will be below the recording.

Any idea when this will be fixed?

Most of the times when I copy a field that is in focus from another project it works.

Really strange behavior.

Maria Campos

Hi Leslie,

Your reply before mine was posted 15 days ago saying the QA team is looking into this. 

My issue is the same as the OP but the text entry field is on a screen recording and not screen shot. I further explain the situation in my previous post.

The issue is the same that is said to be solved in update 5. It is not, or not completely at least.

Please re-read OP and my previous comment and let me know if you still have questions.


This discussion is closed. You can start a new discussion or contact Articulate Support.