"Timeline Starts" triggers not working on iPad

Hi all.

I'm currently developing some game-based eLearning in Storyline 2 and I'm having some issues on iPad. During testing of an incomplete build on the iPad I keep encountering an issue where triggers set to call when Timeline Starts don't seem to operate.

This doesn't happen on desktops in either the Flash version or HTML5 version, it seems to be exclusively on the iPad. I've updated to the latest version of Storyline 2 and I'm testing on Chrome and Safari on the iPad.

I seem to be able to get around this by changing the trigger to call when the timeline reaches 0.1 seconds, for example, but I'm quite far along the development and I'd prefer not to have to go back and implement this workaround throughout. Is this a known issue, and, if so, are there any other recommended solutions?

Many thanks,
Ronnie

3 Replies
Leslie McKerchie

Hi Ronnie!

Triggers that are scheduled to execute when the timeline of a specific object starts or ends may not always work as expected.  If possible, apply these triggers to the slide itself rather than an object to avoid unexpected results.

"When the timeline of an object starts" is the same as saying "when the object is shown".  Likewise,"when the timeline of an object ends" is the same as saying "when the object is hidden".

For example, let's say we have a button on our slide, and its initial state is hidden.  We want to use a trigger to change the button's state to normal, depending on a variable.  We need to apply this trigger to the slide itself, not the button.

Even though the button's timeline may stretch across the entire duration of the slide, our trigger will not work if it is applied to the button itself, because the button is initially hidden.  "When the timeline of an object starts" means "when the object is shown".

If you need us to take a look, feel free to share your .story file or sample .story slide.

Ronnie Wilson-Miller

Hi Leslie

Thanks for the input. Unfortunately the triggers in question are assigned to the slide rather than to objects and are still not calling when the slide loads.

I'm afraid I can't share my actual work due to confidentiality concerns, but I'll try to make a sample Story file to share to demonstrate the issue.

Thanks again,
Ronnie