Too many tabs look selected when building custom tabs!

Hi there!

I'm new to articulate but followed a fabulous workshop by David Anderson (https://community.articulate.com/articles/custom-folder-tabs-video-workshop)on how to build custom tabs.  I have followed all the instructions as seen in the workshop, and mostly, my tabs are working great.  There is just one problem or glitch.  The first time I click through the tabs in preview, everything works great - the selected tab comes forward, changes colour and blends in with the content area.  However, if I then click through the tabs a second time, then 2 tabs change colour and appear selected ( the last one selected and the newest one selected). I think David's workshop was based on storyline 1 as I have storyline 2 and there are some differences in the layout of the software.  Would this be the reason for my glitch? Is there something extra I have to do with storyline 2 that wasn't specified in the workshop? Any help would be much appreciated!!!

9 Replies
David Anderson

Hi Eadaoin,

I made a few changes to your file. The biggest issue I saw was you had the button tabs copied to each layer. I deleted the button tabs from the slide layers except for the disabled cover tab.

Please take a look and let me know if you have any questions. I'm more than happy to record a quick screencast for you!

David

Eadaoin Norris

Thank you so much David! The file I sent you was just the home page of a much larger project but I have applied your changes and the Doubling Effect is now gone! Thanks!

Just one more small thing though.  In both the tabs file that you worked on and my own larger file, the intro tab text  is changing colour when you hover over it, but as it's the selected tab, I would rather this didn't happen.  I tried changing the initial state to Disabled but this just results in the tab becoming inactive.  It's not the end of the world but I was wondering if there is a quick fix I'm missing?

Thanks again for your help!

Eadaoin Norris

Sorry, I didn't explain it well in my above message.  When any of the other tabs are selected, then the intro tab is working fine (hover over and it changes red) and the selected tabs is also working in that it is disabled and does not change red to indicate that it is selected and therefore inactive.   However, when the intro tab is selected and the user is on the intro layer, the intro tab is still changing red when you hover over it. Hope this makes better sense!