Trigger changes wrong button.

Nov 01, 2023

I am finally done with my biggest attempt yet using Storyline and everything seems to be working EXCEPT one of my triggers will not work. On Slide 14.1 there is an Example 1 Button. When you click on it, it takes you through a series of screens 2.1-2.10 and when you get to the last one (2.10) there is a trigger there to make CompleteScene2 = True. Then when you return to 14.1, the Example 1 button should have changed over to the "Completed" state. However, it always changes Example Button 2 to completed. If I do Example Button 2 first it changes correctly, but then Example 1 button still won't work. I can't find the error despite looking for 2 hours. I'm sure I'm missing something small. Any help?

12 Replies
Mary Adams

I have uninstalled Storyline and then reinstalled it. I restarted my computer. I cleared my cache and cookies in the browser. It won't work for me on the storyline file or when I upload it to a learning management system and try from there.

It's even more confusing that it worked for someone else. At least when I thought it was an error I made, it could have just been fixed. What do I do?

Nedim Ramic

I tested the course in Preview mode. I must have skipped something. However, I just took a close look and found what I think it could be wrong. In the "General Transaction 1" scene, there is a trigger in slide 2.5 Notes & Service Costs, that jumps to the "General Transaction 2" scene, slide 3.6 Vendor_Funding Source. Going forward it ends up on slide 3.10 Finished Transaction, where the variable "CompleteScene3" is set to True. Changing Jump to slide trigger on slide 2.5 Notes & Service Costs, from 3.6 Vendor_Funding Source to 2.6 Vendor_Funding Source will fix the issue. This way the user will continue forward through the "General Transaction 1" scene and end up on slide 2.10 Finished Transaction where the variable "CompleteScene2" is set to True.

Mary Adams

Now the memory game isn't working. I even went back to really old files when I am positive every thing worked and it no longer works on those anymore either. Every time I fix something, another thing won't work.  Some of my hovering states changed colors. Highlighting that worked now only works for some of the parts. I feel like I'm going crazy. It all started 2 weeks ago when every text box in the entire thing changed colors (it changed the text boxes to green and the font to a tan color). What is happening?

Mary Adams

Yeah Nedim, I know that one change didn't mess up anything else. Your advice was spot on. I'm just confused at this point.

I am uploading a video that shows an older version on our learning management system, uploaded on Nov. 1st, which worked when incorrect matches flipped back over. However, now when I open Storyline and try those same files from Nov. 1st and before, it won't work. I'm starting to think something must be wrong with my computer or Storyline (it seems like pieces of Storyline keep changing when I didn't change things). 

I've attached an older version of the file from Oct 30th and the latest one from Nov 2nd.

Nedim Ramic

Hi Mary,

I don't think something is wrong with your computer. Your interaction won't work on my computer either. I tried to restore this game functionality by changing and rearranging some triggers. I am uploading a new version here. Let me know if it works as expected. If it doesn't, give me some more details on how it should function to the point where it fully functioned in one of your previous versions.