Trigger not working when published

Hi

I have an object with 2 triggers. Slide 1, object "Lorem".

The triggers are: 1. color change for state "visited" and 2. Show a layer.

It runs fine when I preview only this slide, but when I publish the project, the color change I triggered for the visited state dosen't work.

Any idea how to fix?

Thanks

Shevi

14 Replies
Alyssa Gomez

Hi Shevi,

Thanks for reaching out to us and for starting a Support case! It looks like Anna saw the same issue you saw and reported it as a possible software bug. We tried all kinds of workarounds, but so far we haven't had success. I'm sorry you ran into this problem -- if we do find a new workaround for you, we promise to let you know!

Wendy Farmer

Great Shevi 

I tried a few different things but the last one worked.  Created an identical rectangle called rectangle - lorem overlay with the blue highlight on the word.  Have this sitting on top of the original rectangle in initial state of hidden.  Then on the layer trigger the original rectangle to hidden and the overlay rectangle to normal.

Hope that helps.

Katie Riggio

Wow – thanks for sharing this creative solution, Wendy! I'm going to share it in the bug's report so we can explore this avenue.🌟 

Hello, Shevi! I'm glad to hear Wendy's method helped your project, and we promise to keep you posted here as well as in your case on any changes to this bug. As always, don't hesitate to reach out if you have any other questions!

Christopher Kiely

I have also lost trigger and variable functionality for buttons within a Q&A scenario that (are supposed to) become hidden if the slide they link to has already been visited. Literally worked one day, didn't the next.

While I appreciate Wendy's solution to Shevi's problem this is more of a work around than a solution. Doing this in a case with multiple buttons is time consuming. And what if the triggers for those "overlay" boxes stop working?

Scenarios are an E-Learning norm and immersive ones can have many variables/triggers, having these features just "stop working" is simply not acceptable.

Alyssa Gomez

Hi Christopher,

This issue happens in Storyline 2, but it's resolved in Storyline 360. It looks like you're using Storyline 360, so I'd like to find out more about what you're experiencing.

It would even be more helpful if we can take a look at your project file to investigate what's happening. We'll delete it when we're done troubleshooting. If that works for you, you can upload your file privately to our support team here. We'll give it a test and let you know what we find!

Christopher Kiely

Hi Alyssa

Unfortunately training development waits for no one and we made changes to the presentation to remove the problematic triggers, so I do not have a project file that does not work.

The main issue seemed to be the "hide button" triggers we were using. We created a non-linear scenario that had multiple routes of progression. We were using a "Slide visited" true/false variable that would trigger certain buttons to be hidden if they led to a slide that had already been viewed. The functionality seemed to work fine, then simply stopped working. When we switched the trigger to be a "disabled" state for the buttons it fixed the issue. I have had seemingly random issues with the "hide" trigger before and to me this seems to be the main issue.

Wish I could be of more help.

Katie Riggio

Hi Nancy,

Thanks for reaching out, and I'm sorry you're facing this!

What version of Storyline are you using? Click on the Help tab, then About Storyline.

Also, would you mind sharing the .story file so we can try to find the culprit? You can share the project privately by using this upload link, and we'll delete it after troubleshooting!