Trigger won't perform action

I am trying to get users to type a specified user name & password into a text entry box, then when they are done typing the correct user name & password they are to click another field/hotspot. I want the trigger to jump to the next slide when the user name & password are typed correctly & they click the field/hotspot. I created 2 layers. One layer to appear if they type the user name or password incorrectly and click the field/hotspot. The other layer to appear if they type the user name & password correctly but click outside the field/hotspot. I have included screenshots below.

6 Replies
Ashley Terwilliger

Hi Bonita,

Thanks for sharing the images here - could you share a bit more about what is not working correctly? Which layer isn't showing? It may help if you're able to share the .story file here so that we could take a look at it - but I do see that your triggers for Oops Layer 1 - the first one uses the "AND" condition while the second one uses the "OR" condition - so it seems like there may be some duplication here? 

You can upload the file by using the "Add Attachment" button at the bottom of the reply window. 

Bonita Hayes

Hi Ashley, thanks for your response. When I enter the password, Oops layer 2 pops up but it should only appear if I enter the username and password correctly but click outside the hotspot field. Instead, it pops up before I am done typing the password. Oops layer 1 should only appear if the username or password is typed incorrectly.

I thought I needed 2 triggers for the Oops layers because I was asking the triggers to do 2 different things based on what the user could potentially do. If the user follows all instructions correctly, no layers will appear. 

I have attached the .story file for you. I hope my explanation is clearer. If not, please don't hesitate to ask for more detail.

Walt Hamilton

The trigger highlighted above will make the oops layer 2 show when the user clicks on the text box to enter the password, if the user entered the correct username because the text box for password is outside the hot spot.

Try this trigger

 

Also I had to change the target to close the oops Layer 2. Markers have their own built-in response to clicking.

Also, to advance to the next slide, I had to move Hotspot1 above Practice field rectangle.