Trouble on slide 1 (see attached file)

Hello,

When I click on incorrect objects on slide #1, the "red state" stays still. I'd like that state to disappear as soon as I select another object, as on the rest of the slides. I've also noticed that Storyline renamed "Group 1" to "Shape 1", "Group 2" to "Shape 2", etc but only on the first slide (not on the rest). What can I do?

Thanks.

10 Replies
Christine Hendrickson

Hi there Manuel :)

For the objects' "red" states, you can trigger them to change back to the "Normal" state when the user clicks outside of that group or object. So, when the learner selects another option, that red coloring for the object will go away. 

I've made this change to the Alarm clock in your project. I'm attaching a modified version if you'd like to try it out.

For the groups, it looks like they're actually still named as groups, but they're renamed in the timeline because they contain shapes.

I hope this helps! :)

Manuel Aicart

Thanks Christine, but there must be a problem with slide #1, since the rest of the slides work fine without adding the change of state (try slides 2, 3, 4, etc and you'll see what I mean). Also, the renaming from "group" to "shape" only takes place in slide #1 (the other slides also contain shapes but they keep being named as "groups"). Not sure why this happens. Thanks anyway.

Christine Hendrickson

Good morning Manuel,

Ahh, I see. I took another look and honestly I'm not sure why it's only naming the groups on the first slide as "Shapes". 

However, I did un-group the alarm group on the first slide, then I applied a new group to the objects (I did not use the "Regroup" option). Now the group is actually showing as "Group" in the timeline and not "Shape". 

Oddly enough.. the first slide is now working better with the "Red" selection state after I did this. So, I decided to go ahead and un-group/group all of the objects on the first slide. This seems to be working well on my end now.

Can you take a look and tell me if it looks good to you, as well, please?

Thanks!

Manuel Aicart

Great. It works fine now. I don't want to give you too much work, but I'm working on a similar exercise (see attached file) and I'm experiencing the same issue. On the file you'll see two slides:

Slide #1. The state "selected" (only one object can be selected at a time) works fine.

Slide #2. The state "selected" unexpectedly works as "visited" (how an object appears after it's been clicked).

I've tried what you mentioned in your last mail (un-grouped and grouped the objects several times), but I can't find what's wrong. I've spent some time looking for differences between the slides, but can't find any. Any ideas?

Manuel Aicart

Finally! I checked the slides where the groups showed "Button Set" (none). Then I clicked on "Edit Pick One" and selected the Groups again (even though they were already selected) > Save & Close and that's it, all the groups show "Pick One" Button Sets and the state "selected" works fine. What a relief!