Video Compression (MP4, in AS360) Videos blurred on publication

Hi All,
I'm struggling with unusable screen casts. Here's the story:
I created a series of screen casts in Replay to be used as instruction on data base management. All good. I publish as video and load to AS360. Some will allow me to have no compression, for some, that option is greyed out. I have custom optimisation with setting for video at 9. When I publish the AS file, the videos look awful, with those which had the option for compression missing being fully unusable; text blurred beyond readability.
I have tried importing all to a brand new file and replacing videos with settings at best optimisation etc - no luck. 
Can any one help please? 

19 Replies
Alyssa Gomez

Hi Dorothy,

Here are a couple of things you can do to improve the video publishing quality:

  • Check that your Story Size and video dimensions are similar. If your story size is much bigger or smaller than the video dimensions, you'll have to scale the video up or down to fit the slide, resulting in a loss in quality.
  • Adjust the video quality settings before publishing.

Give those a try, and let me know if it makes a difference!

Dorothy Persic

Thanks Alyssa -  I had already tried those with no avail, so still in a spot of trouble. I had story size at 16:9 and recorded at 16:9, also tried recording at full screen and also tried story size of 4:3 just to cover all options. Also, I still don't understand why some of the videos have automatic compression set with no option to have no compression.
Any help much appreciated.

Alyssa Gomez

Hi Dorothy,

The option to turn off automatic compression is only available for MP4 videos created with baseline, main, or high profiles. All other video files will be automatically compressed when published.

If you'd like our team to have a closer look at your file, you can send it our way by clicking here!

Jesse Anderson

Are you by chance publishing in HTML5? We have noticed degradation in quality of both images and video in the new HTML5 renderer in 360. If we stick with Flash (not ideal at all) our projects tend to have smoother animations and we don't get the compression artifacts we see when publishing to HTML5. 

I spoke with some other attendees at DevLearn last week and they had seen similar issues and had put in tickets with support.

Dorothy Persic

Thanks so much for chipping in Jesse! Yes I have both HTML5 and Flash selected to publish as per client request..... I'm working now with opening in a browser rather than in slide so that has helped a little too, as the videos were scaling to fit.  I'm also wondering why REPLAY doesn't use the correct H264 profiles to support changing / option for turning off compression. I'll ask support via my ticket and get back to you here on this.

Carina Fleissner

Hey,

we have tried following: 

  • save as an .mp4
  • adjust to publish as highest quality
  • set to not compress the file

The quality is still super blurry. Our video is a screen cast of a software programm with lots of fields, text, graphs and we always seem to suffer with blurry videos regardless of what we record the video in (Camtasia, Storyline). Any help would be extremly gratefully received :-) 

Best regards

Katie Riggio

Hey there, Carina!

Thank you for reaching out and for opening a case with our Support team!

I see that Peter linked what you're seeing to an open issue where the screen recording video output appears blurry during preview and after publish. We shared your experience in the bug's report so we can notify you of any changes in its status.

If there's anything else we can do to help in the meantime, please let us know!

TUI People  Development

Hello,

We were experiencing the same issue. Some videos have the compression option "disabled", and they are blurred, and some videos allow to select "none" in compression (not exactly sure why).

I did this to try a solution and it worked. It has to do with how the file is saved (not exactly sure what it is).

1. Upload the video: https://online-video-cutter.com/
2. Save the video again selecting the highest quality  720p or above 
3. Use this "new" video file in Storyline

After that, the compression option was enabled and the video was fine.