Video Compression Problems .....

I seem to be having a different problem myself and have yet to find a way around it.

No matter what file size or bitrate we set the original Mp4 or uncompressed Avi at the compression is entirely to dramatic and is severely affecting the quality of the video.  this is something I have never seen before in any sort of progressive compression.  Even if the compression is set at 9 (least compression) all of the videos are compressed down to around the same size, no matter what the original started out as.

Examples are with the same video file rendered from Sony Vegas at different bitrate then imported and published out of Storyline:

As a designer I render my videos and/or animations to work at the bandwidth and quality suited for our needs.  There should be some option in Storyline to stop it from compressing the videos.  I think it is great that it has great compression but the compression is to great for some of us that has to have more quality.  For our application we should be near 800Kbps and I have yet been able to accomplish that.

So is there any way around this ? 

13 Replies
Mike Enders

Glen,

For now, the only workaround is to output your video to FLV with an alpha channel.  This keeps the video from being compressed by Storyline. However, you are then limited by using an FLV (which isn't HTML5 friendly).  If you would, please submit a feature request to allow less compression:

http://www.articulate.com/support/contact/submit.php?form=feature

Mike

Brandon Driggers

You may already do this, but I have found that by publishing to the exact size of my storyline slides and inserting them, I am either bypassing or drastically reducing the initial compression. My videos show lots of text and this seems to be the best way I can find to keep them usable after publishing without having to create separate courses with just my uncompressed videos. We use Camtasia 7 that does not allow more than one video track so the alpha channel is out for me. Good luck.

Mike Enders

Hi Glen, I'm just coming back round to this.  One potential solution for you:

Starting with a high quality MP4 source file that you've dropped into Storyline.

1. Publish your project

2. Identify the compressed/published MP4 in the Story_Content folder

3. Drop your high quality source .mp4 into the Story_Content folder

4. Rename your high quality source the same as compressed/published MP4

5. Delete compressed/published MP4

Mike

Olga Bogdan

Hi Mike,

I asked you about the video compression on the page "Video compression in Articulate #Storyline. How to keep source video quality."

And I have some problems. I did the same thig that you recommend : Starting with a high quality MP4 source file that you've dropped into Storyline. All the 5 steps. But the result is not the same as yours. My video is not visible even though we can here the audio. What can I do?

Eric Malalel

I follow up on Laka Pele post since I work on the same project.

I noticed that I can display in Google Chrome the MP4 file compressed and generated by Storyline, simply by copy and paste the local file address in Chrome address bar.

If I try to do the same thing with the original MP4 file, it does not show up.

So yes, the issue is in the original MP4 file, not in Storyline, and it's propably related to video encoding.

I have attached a screen copy which shows the difference between the two file properties. Video format and Format profiles are different. Do you think it is related to these properties? Is it possible to convert the original MP4 file so it gets the same properties as the one generated by Storyline?

Carl Boyd

I researched this problem and commented on another thread last week. My team is using updated SL360, and importing videos generated with the same exact output settings that have been working in SL for years. We are making and importing video files set to your exact specifications.

It's also very random: our video editor is exporting separate video files from a single Premier project, using the same exact settings for every file, but every other file is coming into SL with the option to turn off compression greyed out.