Base layer objects (and audio!!) show up in slide layers, even though they should be hidden

Hey all!

I've run into this problem a bunch, and usually I just put a white rectangle to hide the base layer objects. But I'd like a less kludgy fix, if it's available.

Here's how I create the slides:

  • Create a "Click the tabs" slide with objects, background music, and narration on the base layer, along with 5 buttons for each section of the slide
  • Create slide layers for each button
  • Do not pause time line on base layer because we want the background music to keep playing
  • Stop base layer narration audio when use clicks buttons to reveal slide layers
  • In the Timeline of the slide layers, set the objects on the base layer that I don't want visible to Hide

Here are the problems I run into

  • If there is animation on the base layer (i.e. bullets reveal as paragraphs), hiding the text box on the base layer doesn't work. It just shows through. To avoid this, I put a big white rectangle in the slide layer to cover up the base layer objects that aren't hidden.
  • If the user seeks in a slide layer, for instance if they'd like to review something that was just said, the narration from the base layer that was supposed to have been stopped when they clicked the button to reveal the slide layer, starts playing wherever they clicked on the timeline. It doesn't cause the narration of the slide layer to back up, though. It just keeps going wherever it was, but with the base layer narration overlapping it.

I'm guessing the audio deal is caused by not pausing the base layer timeline (since we want the background music to continue) and the only way to fix it is to not allow seeking on the slide layers. But if not, let me know!

And how about the base layer objects showing through?

 

Thanks!!

3 Replies
Crystal Horn

Hey James! Sounds like a handful of your base layer objects are still showing through in the first layer.

First, I would recommend unchecking the base layer in your Slide Layers panel:

slide layers

Then, I would still go over to your timeline, and on the Base Layer dropdown, ensure all the items are hidden:

timeline

While doing that, I was able to retain the audio "soundtrack" on the base layer timeline, but none of my visible objects showed through.

As far as the animated text still coming through, on your layer timeline, that text box item will now have a drop-down of its own. Select that drop-down and make sure the animated text is all hidden on that (or each) layer. You should no longer see that base layer text in your other layers.

My layer properties are set like this:

properties

So I'm not hiding objects on base layer here, and I'm allowing seeking of this layer. You can pause and replay the audio on the layer without changing the audio on the base.

Does this help?  I've attached my example project here, too.

James Jenneman

Thanks for the tips Crystal! The only problem is, when I uncheck the base layer in the slide layers box, it makes the slide title (sort of the big headline) and the buttons to get to the other slide layers disappear. I do have everything on the base layer (other than the headline and the tab buttons) hidden on the timeline of the slide layers, though.