An annoying bug when typing text in paragraphs

I've been encountering a rather annoying bug when writing paragraph text.

Here's the steps I am doing at the moment:

  1. Type a word.
  2. Hit space.
  3. Type the next word.
  4. Delete the word, but not the space before it.

Rise has been automatically removing the space before the deleted word for me, triggering me to mistype merged words. You can see what's happening in the video I've attached.

I assume the code is constantly stripping trailing spaces.

It doesn't seem to happen all the time though, just enough to make me re-type often.

10 Replies
Hazel Bartolome

Hi Sharon, sorry this is happening to you. Can you try to access Rise in Incognito or InPrivate window? Pressing Ctrl + Shift + n for Windows, or Press ⌘ + Shift + n for Mac switches you to Incognito mode and disables all browser plugins. Sometimes plugins cause odd behavior, do you still get the same issue when in Incognito?

Jacob Davies

I am currently experiencing this issue. It was intermittent initially but now is constant and I have tried in both Chrome and Firefox. No plugins or browser extensions are installed. Also happens for a colleague of mine.

We are currently using Rise exclusively for a project and though we are putting up with it is not ideal and should be sorted out. Clearly causing issues for a lot of paying users!

Crystal Horn

Hi folks! I have seen this issue happen when there is text that starts the line, and is formatted, or had been formatted (bold, italic, etc). Are you all seeing this occur with formatting changes, or does it seem to occur no matter what? 

This link shows a quick screencast of how I've reproduced the issue. The workaround at this point is not to start a line with formatted text, but instead to apply the formatting after you've completed the paragraph. We've documented this for a permanent fix!