Republished Courses No Longer Report Scores to LMS

I've republished courses that reported the score to the LMS before and now they are not reporting the score at all. This is happening in all of my larger courses with knowledge checks and a final assessment. I am publishing as SCORM 1.2, Track using quiz result (final assessment), Reporting Passed/Failed. In Blackboard, it says "Need Grading" and shows a score of zero. This doesn't happen with smaller courses with only one knowledge check so far. I've tested it in SCORM Cloud and the score was not reported there either. Again, these courses worked perfectly and reported the scores when I published them previously back in February.

17 Replies
Veronica Volz

Ok, I've tested it in both Blackboard and Moodle. When there is only one quiz (within a block), it appears to report the score. When there is more than one, it doesn't (it now says "In Progress" in Blackboard instead of "Needs Grading", but in Moodle there is no indication that it was attempted at all).

I tried several tests in which I would add and remove blocks, activities, parts, etc. The only culprit seemed to be the extra quizzes. Once I remove all the quizzes so that only one remains, it works. But as I said before, my courses have several quizzes.

I'm using SCORM 1.2, passed/failed, and track using quiz results. Let me know if I can be of any further help.

Veronica Volz

So Gren has been able to replicate the issue and has sent it to the Engineering team. Please know that this issue has had a very significant impact on my work. I've been asked to make changes and cannot until this is fixed. Will it be prioritised to be fixed in the next update? 

Ashley Terwilliger

Hi Veronica,

Sorry for any confusion! That fix did get pushed out - but the issue our team identified with your course goes a bit deeper. Our team is looking into a more specific behavior based on your report where the completion and score are not sent to the LMS if you have 2 or more quizzes in your Rise course. 

I'm going to check in with the team this AM about that issue - so I'll be in touch as soon as possible!