Exit Now button not working

I have searched the archives here and google and so far, what I am seeing is not helping my issue. This is a new problem as this function was working fine the other day. I checked and it looks like a new flash update happened, but I cannot get an older version of flash to work either, so not sure if that is what caused this.

The issue is in my LMS, if the Exit Now button is not pressed, the score doesn't get sent to the LMS and the resume data is not set...so people that have finished the course are getting no score and are taking it over and over again trying to get it to go away.

I am on IE9, pop up blocker disabled. What happened?!?! 

I even tried one suggestion on the Articulate board that said to change the player configuration to have the exit behavior "ALWAYS_CLOSE_TOP" and that seemed to create bigger issues and my LMS is now not allowing the SCORM package to be uploaded.

9 Replies
Gina Hoekstra

I see that this is NOT a new problem in the IE9 world, however it is new to me. I don't understand why it would all of a sudden become an issue.  I have no choice but to use IE9 and the compatibility issue doesn't solve my problem because my LMS pops up in another window without the toolbar to set the compatibility with. I tried to make all compatible, but that didn't work either. I heard it could be a flash issue, so I tried to go back to an older flash...still no luck. This is very frustrating.

SIM Khoon Huat

Gina, you are not alone. I have also encountered this issue. In fact the Finish button in the results page of the Quizmaker assessment that I have included at the end of the courseware is also not responding. I suspect this is also due to the same reason as to why the Exit Now feature is not working.

will probably also open a ticket for this. Hopefully something can be done soon.

Jose G. Sanchez

Gina Hoekstra said:

I will open one, but it would definitely be nice to see a resolution on the board since it doesn't seem to be an issue that is just related to me. Thanks for the ticket link...I have never done that (I always seem to find the answer here until now). :-(


I had similar problems until I noticed that I changed the default tracking setting on Reporting and Tracking screen. I placed a lower number of slides than the presentation have (wich is the default value). It seem like there is a bug in the 09 presenter version.

David Flass


I thought I was having the same problem; the Exit Now button in some courses that i compiled a month ago worked just fine, but ones that i did in the past few days didn't work. But then we realized that a month ago - to avoid problems like this that we were having - we decided to package for web instead of for LMS, and forego any tracking other than completion by access.

Where Articulate could make an improvement is to include all publish settings within the player templates so that we won't have to remember or record additional notes on how we published.