inserted videos go larger

Hi Everyone,

I couldn't come up with a way to fix the newest faults Presenter has thrown up so I badly need help - I must say I am reaching my limit of patience with Articulate and seem to be finding more bugs than features and it is just not reliable around deadlines.

1.) This time I am having an issue with inserting video into presenter. it is an flv file type and is 1533x856. As Presenter is very particular about the file size it can have in-slide this one is opening in a new window. Except when it opens it is much bigger than those dimensions - I used those dimensions so it would happily fit on a 1600x900 screen.

It doesn't - for some reason when you play it from the published file it is way off the screen. Does anyone know why this is happening?

2) When the published file starts and even though it is set to standard view with the Presenter bar for some reason the first slide starts as if it is slide only, with the presenter bar cutting out about a third of the slide.

I've set it to standard view in every place. If I press the change view button in the presentation and toggle it back to standard view it is fine - it just starts all messed up.

All help appreciated!

6 Replies
James Brandwood

Thanks Rich, but these videos are set to 'open in a new window' so the size restrictions that you mentioned don't apply. Actually they are the reason I don't have videos show in the slide because I do a lot of software demonstrations and it helps to have a larger screen shot.

In saying that this is the largest dimensions I have done because it involves 2 software programs and it is easier to show them both pretty much side by side.

Peter Anderson

Hi James,

Sorry for the frustration. Have you had a chance to review our Flash movie best practices? Also, If you need to maximize the window that an inserted Flash movie opens in, you can modify the HTML page that is actually loading the Flash movie. Here's how:


Please be aware that this method is not officially supported by Articulate.

1. Publish your presentation.
2. On the Publish Successful dialog, click the Open Folder button.
3. In the published output, open the Player folder.
4. Open the VideoPlayer.html file in a text editor, such as Notepad.
5. Edit the following code:

Change this:


var g_nWidth = "100";
var g_nHeight = "100";
var g_strSearch = document.location.search.substr(1);
var g_arrSearchArgs = g_strSearch.split("&");


To this:


window.moveTo(0,0);
window.resizeTo(screen.width,screen.height);
var g_nWidth = "100";
var g_nHeight = "100";
var g_strSearch = document.location.search.substr(1);
var g_arrSearchArgs = g_strSearch.split("&");


Essentially, the above code change positions the window in the upper left corner and then resizes it to maximum. These attributes can be manually changed to anything that you need. If you want to just maximize the window, you can change the window.resizeTo value to something like this:

window.resizeTo(1450,900);
Justin Wilcox

Hi James.

I could not duplicate your first issue. Here's a quick presentation I did to test it out. I would really reconsider how you are going about this for a couple of reasons.

  1. The dimensions 1600 x 900 is really limiting your audience. I have a variety of computers, all with different screen dimensions, including a 4x3 monitor whose ratio does not match that and pixel settings would not allow that to fit into the screen.
  2. All modern web browsers block pop ups by default. The code used to open a Flash movie in a new window in Presenter would be blocked by virtually all of them unless you specifically allow the content to open pop ups or if you happen to have pop ups disabled. Making someone allow a pop up to view a video breaks the flow of a presentation, especially when the video is too large to fit on a screen.

I would recommend considering using the No Sidebar view for your video and re-recording it at 980x560. This will allow you to create a video larger than 720x540 that will play within your presentation.

For your second issue, there are a couple of different places that you need to check to make sure that your presentation is launching in Standard view and not Slide Only view. I've created a screencast I hope helps you out:

James Brandwood

Justin:

Thanks, They are all great considerations that you mentioned in regard to video size and usually would be spot on, but in this case I am working for a company to create training modules for their in-house software. You can't resize this software's window so to get it to fit into the PowerPoint standard sizes I can only shrink it and that makes reading the screen really hard. I do have the advantage of knowing that this training will only be viewed in the workplace and on monitors that are fixed to 1600x900 and with pop-ups from the LMS allowed.

This is a unique circumstance I suppose and I do agree that opening in new windows disrupts the training flow but it is necessary in this situation.

On that second issue -

Thanks for the screener, I was setting the view for the first slide in Player Templates and this may have been the problem but I gave up trying to figure it out and just grabbed one of the other modules (it was one of 3, all with the same settings - the other two worked fine) and renamed it and copy-pasted all the broken modules parts into it. Then I forgot I was going to upload the file and deleted it. oops. I really wanted to put it up too, because it wasn't that it opened in the wrong view, rather a mix of two views.

Peter:

That's great info to have, when I am not so busy at work I am going to sit down and try play around with that and see what I can get to happen.

As hair-pullingly frustrating Articulate can be, it is the level of support that keeps me using it.