Problem with publishing pdf as an attachment

Hi gang!  Having a problem with pdf as an attachment.  No problem creating a course that has a pdf as an attachment.   When I preveiw the course from within articulate the pdf opens fine as an attachment.  After I publish (and before zipping) and preveiw the presentation the pdf is no longer there.  The pdf is also not there after uploading into the LMS

11 Replies
Neu Bee

Thanks did some testing and pretty confident it is a setting in articulate.  It would be easier to explain over the phone but I will try below.

All the courses are pretty much the same format, we are using them to roll out and train on SOP's

Copied a folder of course that was working, redid the working course inserting the pdf from the course that was not working.  No problems veiwng the course after publishing but before zipping

For the course that is not working, redid it with the pdf from the working course and cannot veiw the pdf by clicking on attachment after publishing but not zipping

diane snyder

I am having trouble with the pdf's not showing when I move the folder to a shared drive.  I published all the files to a folder on my hard drive the pdf attachments launched fine.  I then copied the publish files to a shared folder on the network and the attachments will not launch.  I am publishing to an LMS.  So from my hard drive the files work; from the shared they do not.  I tried renaming the files to Gloss.pdf instead of Gloss_of_terms.pdf and it does not make a difference.  Any ideas?

One more thing I noticed.  After publishing the files - a pdf that is on my hard drive named Gloss.pdf - after publishing - in the download folder - it somehow renames itselft to gloss.pdf (lower case) - I tried renaming the file to capital but it still would not launch from the shared drive after being published. 

I read that published files to an LMS will not launch the pdf files as attachments unless they are launched from the LMS, but then why do they launch after being published on my hard drive?

Justin Wilcox

Hi Diane and welcome to Heroes! Due to security restrictions witch active content in a local environment, this is expected behavior. The reason that it works on your local drive is that we add a trust file that allows it. You should test your content in the environment where you plan to host it.

Hosting content on a shared network drive is not recommended due to the security restrictions noted.