Attachment problem


I'm having problem with the PDF file set as an attachment in the Ariculate Presenter.

On the preview mode, the attachment is fine, but after publishing it, there appears page with any strange letters, signs and numbers (just like on the printscreen below).

I didn't change any settings on the web browser or on the publishing panel. I published several trainings this way, and there was never any problem with the attachments.

Could anyone HELP?

8 Replies
Nancy Wilkinson

Hi Joanna,

Not sure if this will help, but we ran into something like this and it was due to security issues on the PDF. Here is a link describing security aspects for attachments, although it was intended to address attachments that won't open;

In our case, we had security set on the PDF document, so that might be something to check too.

Joanna Kurpiewska

Well, after reading this suggestion I solved the problem. But only for the IE browser. It also works fine on the Opera. But I still have problem with the Firefox and Chrome. Fortunately after publishing it on the platform it works fine. So the final user has no problems to view the attachments on any browser (but I'm still searching the solution)

Justin Grenier

Good Afternoon, Joanna.

One of the most useful pointers for testing your published content is to be certain that you are performing your testing in its intended environment.

For example, if you are publishing for Web, you would need to upload the published contents to your web server for accurate testing.  If you want to test your content locally, you will need to publish for CD, then use the Launch_Presentation.exe file to launch your presentation.  The recently-discovered Chrome bug is just one reason that this is a good idea.

Please let us know if you need anything else.  Thanks!

tim lambert

Hi all,

I'm experiecning a similar problem. I have some PDFs which I'm linking to through the attachments area on a Articulate Presenter course. Opening the attachments works fine for me in Chrome and IE7 8 and 9. But it does not appear to work for my client who is also using IE8. The course is online, we are accessing exactly the same link.

I've looked on some of the suggestions on the forums and have tried the following:

  • In Internet Options > Security > Custom Level > I've selected: Automatic prompting for file downloads" to Enable and "File Download" to enable
  • I've checked that popup blocker is not enabled.
  • In Adobe Reader preferences I've ensured the 'display PDF in browser' option is checked
  • I've also reset Internet Options > Security settings to Default

None appear to have any effect. The cleint doesn't receive any warnings asking to unblock etc.

Does anyone have any suggestions that may help?