Can't save Survey in '09- error message

Just got a new laptop, and for my first project in Articulate studio '09 since my tech dudes set me up, I tried creating a 1-question survey.  When I finish creating the question and click "Save and Return to presenter" I get this error message:

"System.Runtime.InteropServices.COMException (0x800401F9): Retrieving the COM class factory for component with CLSID {C95F3816-578E-4CCB-A51C-382C522C6F38} failed due to the following error: 800-401f9."  then a list of 2 Articulate.Drawing Imaging and 2 Articulate.Design references.  When I use the "X" to just close it, I get an "unhandled exception error."

Any ideas what's going on????

5 Replies
Brian Batt

Hi Jo and welcome to Heroes,

I apologize for the issues that you are having. Could you please do the following to see if it resolves your issue(s)? 

1. Install Microsoft .NET Framework 2.0 Service Pack 1: 
Download details: .NET 2.0 SP1 (x86) 

2. Run Windows Update: 

Microsoft Windows Update 

3. Restart your computer 

4. Use the following method to repair your installation of Studio '09: 

1. Go to Start -> Control Panel. 
2. Select Programs (Vista) or Add or Remove Programs. 
3. Select the Studio ‘09 program and select Change or Remove. 
4. Select Reinstall. 
5. When the installation completes restart your computer. 
6. Open the software that you were having problems with 
7. Attempt to replicate the issue. 

=====

If the above does not cure your issue, make sure that you have Flash installed by using the link below: (please use Internet Explorer when installing Flash)

Adobe - Adobe Flash Player

Then, restart your computer & try to republish the file. If you continue to have problems, please let me know.
Jo Chamberlin

Hello, Brian-

No the fix didn't work. Nothing in Articulate is currently working on my laptop. 

My desktop support guy tried this:

1. Install Microsoft .NET Framework 2.0 Service Pack 1: 
Download details: .NET 2.0 SP1 (x86) 

but it failed.  We are currently running version 3.5 of this, but reloaded it just in case.

2.  Also tried loading Studio 09 update 8.  Load was successful, still have the problem.

3.  Yes I have Adobe Flash loaded.

Open to any new ideas about how to get back in action-