64-Bit Storyline 360

Is there a way to access a 64-bit version of Storyline 360? I noticed what I have installed through the 360 suite is only 32-bit and I'm finding that I may be reaching a ceiling with performance while developing my courses. I click on pretty much anything in the app and have to wait a full second before Storyline 360 responds. This has slowed my production down significantly. I was wondering if there's a way to get a 64-bit version or if anyone is having a similar issue.

Thanks

41 Replies
Ashley Terwilliger

Hi Muhammad,

I'm sorry to hear about the crashing! Did you already go through the repair steps as Leslie had mentioned before? If so, and you're still running into difficulty I'd like to have you work with our Support team. They'll be able to pull some error logs, to help determine what may be causing the crash. 

Leslie McKerchie

Hello Charlotte!

I cannot speak for Muhammad, so hopefully he'll be able to chime in. It does look like he reached out to our support team, but no confirmation if the steps there was able to alleviate the issue.

You are certainly welcome to reach out to the user directly via the 'Contact Me' option on the user profile if you do not hear back soon.

Please feel free to reach out to our support team here if you need further assistance.

Andrew Runkle

The issues seem to start showing up once there are several slide layers being used on multiple slides in the same scene. My workaround was to create a new scene to place content on a blank slide in order to work without a delay, then copy everything I had done in that slide to the slides that slowed down previously. This was the only way to finish the project. I've run into this issue with multiple projects now. I don't think Storyline handles several slide layers very well. Hope this workaround helps save someone some time.

I'm 99% sure this is not my system, as I'm working on an Intel i7 with 32 GB ram and gtx 960m on a 1TB SSD.

Diarmaid Collins

I run Storyline 360 on my Mac using Parallels 10 and have the app as an icon in my Dock.

I applied the most recent update (October 12, 2017 (Build 3.9.13567.0)) last night and noticed that today it is extremely sluggish and unresponsive.

I realised that there was a second icon in the Dock titled Articulate Storyline 360 x32 which is what was running. The original icon does nothing now when clicked except run a dialog box that disappears almost instantly...

It seems to be targeting the installer but it has always opened the application itself whenever clicked in the past.

It does look like the recent update is opening a 32-bit version of the software and it runs terribly on my machine.

Is there even a 64-bit version of Storyline 360 yet?

Screenshot

 

Alyssa Gomez

Hi Diarmaid!

Really sorry you're running into trouble. I also use a Mac with a virtual machine running Windows 10, so I wouldn't expect Storyline to be sluggish and unresponsive there. 

For now, the Articulate 360 apps are 32-bit programs, and we do not have a different version available.  If you'd like to see a 64-bit version, you are welcome to share your thoughts with our product development team here!

It sounds like your system meets our requirements here, so let's first try repairing your software. If that doesn't help, reach out to our Support Engineers using this form. They're around 24/7 to help!

Diarmaid Collins

Thanks for responding Alyssa. Yeah, my system has been well able to handle Storyline till now. I have followed the "repairing" instructions and indeed, Storyline is opening with a regular ol' Articulate Storyline 360 icon in the dock.

Things seem to behaving a little better except there are a few glitches that seem to have crept in with these recent updates:

  • Clicking the "Replay" button within a slide preview fails to replay the slide most of the time. I have to click "Close" then "Preview" again in order to review the slide.
  • Looped animations (movies) in the background on the base layer now fail to loop when published. They behave perfectly in preview, but seem to fail when published.

There are a number of other clunky things that I cannot remember right now but I'm beginning to realise that updating immediately is probably not a good idea, if things get broken as a result.

And my initial point remains that something in the last update caused Storyline to open an app called "Articulate Storyline 360 x32" in my Dock. Weird. 

And not reassuring.

Ashley Terwilliger

Hi Diarmaid, 

I haven't heard of similar reports of those two issues in the latest update, nor have I run into them myself. I'd like to have our Support team reach out and work with you figure out what is happening with how Storyline is opening and the other behavior you saw. Is it okay if they reach out to you directly? 

Emily Chorley

Hey Diarmaid,

Did you manage to get your issue rectified? I'm currently facing the same issues and its crippling me work wise, I can barely work at all with these constant problems.

And on top of that the amount of support I am having to ask for is unreal, problem after problem and although I am getting a lot of replies I am basically being told that its an error at my end which feels more like a fob off than any actual help.

Emily.

Diarmaid Collins

Hi Emily. I am sorry. I feel your pain. 

I never followed up on these specific glitches with the Tech Support team. I encountered other issues (broken animation effects) which took priority.

After highlighting these other issues  (in another thread), someone from Articulate got in touch with me and supplied me with a link to an earlier version of Storyline (Storyline_Stable_Release_3.9.13567.0) which has performed very well for me over the last few weeks.

I am never updating again.

 

Emily Chorley

Its just so ridiculous! I'm fortunate enough to have a pretty experienced brother when it comes to tech support and he spent a good few hours trying to tackle the issue.

We can comfortably say that we have found that the issue 100% lies within Storyline and managed to replicate the crash error over and over again by forcing the capped memory of 2GB to go over 2000 (hopefully that makes sense as i'm not so technically gifted!) and then as soon as it peaked above 2000 low and behold the errors came up.

Im currently trying to backdate another work PC down to Windows 10 - 32 bit to see if I can replicate the issue there as well and then I'll know for sure if the error lies withing the 64GB OS.

How on earth more people aren't experiencing this I just don't know?! 

 

Emily Chorley

Hey again Diarmaid, 

I think I may be getting closer to finding a reason for the issue we're having - for me at least it seems to be to do with my SL account as no matter where I log into it, UK, Portugal and regardless of the spec of the PC it is only my account that has problems, when testing it with trial accounts here are never any problems. 

So my thinking is that its to do with the amount of courses I currently have uploaded on Articulate review, I have somewhere upwards of 150 - so I'm interested to find out if you have a lot of courses uploaded as well?

 

 

Diarmaid Collins

Hi Emily. I had a nice long and detailed response to you just now but when I hit Post Reply the site disappeared and I got the "page could not be found" error.

Either my internet connection is wobbly or Articulate do not like criticism of their software (cue X-Files music)... nah, it is definitely my internet connection.

I was just saying that no, unfortunately, I do not use Review so my issues did not lie there.

My points mentioned above stem from an update (either buggy or corrupt) that presented an unusual number of glitches. But the instructions to re-install a fresh copy did resolve the main concerns, until a later update broke other badly-needed functionality.

There are ALWAYS glitches with Storyline - I usually cannot afford the time to extensively diagnose the cause of them all. My setup is a 5K iMac running Windows 10 via Parallels Desktop 13. There are so many potential breaks in that chain it freaks me out where to begin...

My frustrations generally lie with these support pages and the fact that when I do take the time to resolve issues I find a relevant post but it turns out to be 2-3 years old, and obviously, still hasn't been resolved.

A current bugbear with Storyline is that there is now a significant lapse in time (almost a second) before I perform an onscreen action and the display catches up with the intent.

I am really sorry that I cannot help you with your issues. I fully understand your frustrations. 

Emily Chorley

Typical, that usually happens to me too!

I'm the same as you with the whole glitches thing, as soon as a new version of SL appears I upgrade immediately in the hopes that all the bugs I've encountered are wiped out for good, and yet as usual there's just another one around the corner!

its a shame you don't use Articulate review as after getting fed up of waiting for a fix from Articulate I had to bite the bullet on my hunch and basically deleted 80% of the courses I had uploaded waiting for review and low and behold my SL works absolutely fine again!

I have the Team subscription so am pretty annoyed that I've had to do this as my main reason for getting this subscription was so I had unlimited upload space as I always have a tonne of courses  on the go, but maybe I've missed something here and there is actually a cap I was unaware of.

Sorry to hear you're still having issues, fingers crossed they'll get sorted... one day at least!

Ashley Terwilliger

Hi Emily, 

I'm sorry to hear you deleted courses from your account, I can only imagine how frustrating that was.  I see that Victor shared some additional steps that you aren't able to go through at this time, but our team will continue investigating your account and anything that could be causing this oddity as it's certainly not something we've seen before.

The 360 Teams account does have unlimited storage, and I also know of many other users who are uploading a tons of courses there and have yet to run into the same issues you have. I know that doesn't fix or solve the issue you have, but I hope it at least can reassure you that the issue isn't the general upload/storage allotment but something in your account.

We'll continue to work on the issue and keep you posted with any updates. Again my apologies, and if there is anything else we can help with please let us know here in ELH or connecting with our Support Team directly. 

Katie Riggio

Hi, Jan. Appreciate you adding your voice!

While we don't have a timeline to share regarding a 64-bit version of Storyline, we are actively working on improving its memory usage and performance.

I shared this topic with our team, and we promise to share all the improvements here as soon as we release them. Everyone who commented here will be notified immediately since that automatically subscribes one to this discussion. Stay tuned!

Jan Zet

Thanks for replying on this dramatic request.

I can only imagine, it is dramatic not only on my end.. And hope you all can imagine, that we do not make stuff in SL only for fun. Our businesses depend on proper and reliable tools. We simply cannot make our organizations, customers and their customers more efficient and happy if our tools fail. I have a SL project that runs all over the world and will replace another that has been presented do +4000 industry experts on +500 training sessions. Now, .story line of 3GB cannot digest any simple thing added more and crashes...

One of the strange things is cashing non-used, duplicated media inside the file, which for sure is not without influence on the overall reliability.. nobody on earth can guess what is what in the files structure with the very convenient name system and moving out some of the duplicates makes the file unplayable.