A question on the user interface

I use the show/hide button a lot on courses that contain many objects. I also use the group function to make things a little easier to manage. Let's say all my objects are visible and I click show/hide all to turn them all off. I move down to one of my groups and click the eye to turn it on. My expectation is that all things within that group should now be visible. But they are not. In fact, nothing but the group selection box is visible. A random, non-scientific poll of my peers confirms my expectation: that you should see everything in that group. I'm trying to understand the logic here. 

6 Replies
Walt Hamilton

It is a know bug that certain methods of hiding and showing items (groups, textboxes with animation by paragraph) do not always apply to the children.

For example, if you hide a parent, then expand it, and unhide it, none of the children will show. But if you contract it, then unhide it, it usually works.

My standard workflow is when I'm through working, I use the hide all button, then the show all button, as that seems the most reliable method of re-showing everything.

Michael Shannon

I'll accept it as a bug since the expected behavior should be that when you click on a group the children should accept the action of the parent. Is this on the bug list? I've been experiencing this behavior for quite some time and as our courses become more complex this adds to the frustration/time cost of development. 

And as you Walt and Les indicated I do the same thing when I'm finished with the edits (hide all/show all) but this isn't my biggest issue. Mine stems from working with a timeline with 40 or 50 layered objects and groups. When you need to drill down to one object quickly it's not possible. You have to turn off all layers and then one at a time work from the bottom up to reveal them until you've isolated the one you have to edit. 

Ashley Terwilliger

Hi Michael, Les and Walt, 

Thanks for sharing your experience and those steps here. What I was seeing is that Show/Hide All causes the groups to not show/hide later on using the individual options. That is something we have reported as a bug and here's a quick Peek video showing what I'm seeing. 

Show/Hide an individual group or items in a group does appear to work though. Let me know if you're seeing something different! 

Alyssa Gomez

Great news, folks!  We just released another update for Articulate 360!

Remember the issue you had with the "Show/Hide All" icon and grouped objects? That's now fixed!

Just launch the Articulate 360 desktop app on your computer and click the Update button for each application. Details here.

Please let us know if you have any questions, either here or by reaching out to our Support Engineers directly.