39 Replies
Mike Enders

Susan,

You can do this via a web object.

1. Have all of your Engage output in one folder.

2. Rename your Engage.html (Studio 09) or Interaction.html (Studio 13) file to "Index.html"

3. In Storyline,click insert web object and click on the folder icon. 

4. Direct Storyline to the Engage folder (just select the folder, no need to navigate inside).

5. Click Ok.

Now, when you publish, all of the Engage files will get pulled into your presentation.

Hope this helps!

Mike

Allen Williams

I have followed Mike's directions and inserted an Engage file into a Storyline slide as a web object, I can see it all OK and the engage slide works fine, but the Engage slide size is larger than the allocated slide space in Storyline and scroll bars appear. I tried to adjust the web object size, but that did not help.

Is there any way I can match the engage file size to the storyline requirements?

Susan  Parnell

I'm just getting around to doing this now. 

I've got an 19_Engage folder with all the data and videos in.

and I've got 19_Engage shockwave.

I put both into a folder and renamed: Engage.html.

When I tried to upload as a web object - the message says: could not locate index.html file?

Thanks

Sue

Mike Enders

Susan,

Did you rename the folder, or the "engage.html" file?  You'll want to rename the file (not the folder).  So to recap...

1. Publish out your Engage project for the web.

2. Inside that published output folder, rename the engage.html (if you're in Studio '09) file to index.html

3. Insert a web object in Storyline and browse to the folder.  The folder is the target, not the files inside.

Mike

Rebecca Hayes

I followed these steps, but when I publish my course, the slides that should show engage interactions are blank. Can you offer any further suggestions? None of the interactions from Engage show up, nor do my websites that I embedded (I posted a separate question for that, too). Am I looking at the published course incorrectly?

Thank you,

Rebecca

Gayla Keesee

Allen Williams said:

I have followed Mike's directions and inserted an Engage file into a Storyline slide as a web object, I can see it all OK and the engage slide works fine, but the Engage slide size is larger than the allocated slide space in Storyline and scroll bars appear. I tried to adjust the web object size, but that did not help.

Is there any way I can match the engage file size to the storyline requirements?

I have the same question that Allen does. Also, is there any way to remove the Next and Prev buttons  I see that I can disable the Volume and Seekbar, but not the buttons. The difference in size is also a problem.
yuting chien

Gayla Keesee said:

Allen Williams said:

I have followed Mike's directions and inserted an Engage file into a Storyline slide as a web object, I can see it all OK and the engage slide works fine, but the Engage slide size is larger than the allocated slide space in Storyline and scroll bars appear. I tried to adjust the web object size, but that did not help.

Is there any way I can match the engage file size to the storyline requirements?


I have the same question that Allen does. Also, is there any way to remove the Next and Prev buttons  I see that I can disable the Volume and Seekbar, but not the buttons. The difference in size is also a problem.


hi Gayla:

About hide previous/next button issue,  you can click Interaction Properties / Playback/ uncheck "Show previous/next button". 

Rebecca Dutton

I can't seem to figure this out.  Any ideas on what I am doing wrong?

1. I go to engage and go to publish and choose web

2. Then I click open folder and find the interaction_html5  file and rename it index.html (or index_html)

3.  Next, I go to Articulate and insert web object.  I find the entire folder and insert it but then I get a pop up saying it can't locate the index.html file.

Erika P

Mike Enders said:

Allen,

Could  be a few different things...but here's what I'd try first...

When you publish out your engage interaction, set it's properties to resize the player to the browser window.  This might do the trick.

Mike

Can you explain how to do this Mike? I don't see these options in the Engage properties (09).
Christine Hendrickson

Hi Wendy,

I'm glad I caught this, I just responded to your other thread.

If you're inserting as a web object, keep in mind that you won't see web objects while previewing or when viewing the published files locally. You'll want to upload to a web server or LMS to test the web object.

If you view a published Storyline presentation on your local hard drive or send it to someone else to view on their local hard drive, you'll encounter security restrictions from the computer, web browser, Flash Player, and network that'll cause various features of your content to fail.

To properly test your published content and share it with others, upload it to the environment for which it was published. Please review the article below for more information:

Publishing and Sharing Articulate Storyline Content

  • I suggest using SCORM Cloud for your course - it's a great place to test SCORM content.
  • Another option would be to use our Tempshare server. Just keep in mind that this server is only available for testing content - it is not officially supported by Articulate and all content will be removed automatically after 10 days.
  • You're always welcome to try out Articulate Online, as well - it's available for a free 30 day trial.
Christine Hendrickson

Hi there Gayla,

Are you able to share your .story  file here? If so, I'd be happy to take a look and see if I can figure out what's causing the trouble with the web object.

If you're including an Engage interaction as a web object, it may help to zip both the .story file and the .intr file into one compressed file. This way you can attach both at the same time, if they aren't too large in size. 

Thanks!