Adding local web object in storyline

The project I am working on requires a web object to be displayed. Earlier, we hosted it on our server and we were displaying it in the same slide. Now, after reading this tutorial about adding web objects, I wanted to give local web objects a try. So instead of the web link, I provided the path on my local pc. But after publishing, the web object doesn't open.

The web object  (on my pc ) uses javascript files and images which are included in the folder. The name of the html file is index.html.

But it is not working? Am I missing something?

The purpose of local web object instead of online web object is that we can use it offline.

14 Replies
Gerry Wasiluk

I'd try not providing the path to files on your local PC in the web address area for inserting web objects.

Instead, use the folder icon to navigate to the top level folder holding your web object and select that.

That should draw in everything in that folder, including any subfolders.

Make sure your folder has a index.html or index.htm file in it that launches the web file.

I use web objects all the time, though I tend to create my own and only have things at the folder root level and use relative linking.

pappu kalani

@Mike & @Gerry

Yes. The output folder pulls in all the required javascript files and images and displays the html file(which is named index.html) perfectly in browser. But when I try to open the index.html in storyline by adding local web object by the exact same method as Gerry, it displays a blank page.

Derek Laur

This might sound silly, but when you resize the web object, it seems to cause this issue for me. Are you resizing the web object? If so, try publishing the project without resizing it. Let me know if this helps. If this causes the content to load properly, next try resizing it using the web object tools .

Let me know if this helps.

It seems a lot of the old features in articulate presenter do not work nearly as well and are glitchy. Inserting SWF videos and HTML content is giving me a headache with Storyline

Dennis Hall

Hi:

I am unable to display a WebObject when I run the finished project from a USB key. The WebObject does not display.

The same story project runs and displays the WebObject when I run it from a web server, but not a local drive.

I have the web page in a sub folder within the story_content/WebObjects folder and it all works no matter what web server I put it on.

I need to run this project from a USB key.

Can anyone be of assistance?

Christine Hendrickson

Hi Dennis,

First, the USB source is definitely the issue. It's seeing the content as launching locally (which causes problems) and the content is launching from an external source (with also causes a lot of problems). This is due to restrictions and other limitations.

I, personally, have not used a USB key. I'm assuming you mean a USB drive? I have no idea if this will work, most likely not, but you could try publishing the content for CD, then launching the .EXE file from the storage device. Of course, this suggestion may only result in a few laughs from the community - but might be worth a shot if no other methods or suggestions are shared for this.

I'd like to know how this turns out for you. Let us know what you find!

Christine

Dennis Hall

Thanks Christine:

I had published this product as CD for Windows PCs, then renamed the output folder, I then published the product as Web so we get the iOS Player for Mac and iPADs as well as HTML, HTML5 and Unsupported output for other devices.

Unfortunately, we are not able to host the content on a web page due to the sensitivity of the content. The only possibe delivery medium is USB key. Specifically, the only issues are with the HTML type outputs.

When I develop in Flash, I can use a CrossDomain.xml file, however, I do not have that option with any Articulate products.

Is there a solution in the works for this type scenario?

Best Regards,

Thomas Ribo

Here's the process :

1. Create a new story.

2. Create index.html with an embedded pdf file in a folder named "webobject" located in the same directory as your .story.

3. In the first blank slide, Insert/WebObject

4. Choose the webobject folder after clicking the directory button.

5. Publish. No "WebObjects" folder can be found in output/story_content

Same process with you webobject located anywhere else on your hard drive (me : D:\webobject). It works.

The embedded PDF file with object tag does not work on iPad though, but I assume this is a different problem. Any idea?

Mike Enders

Thomas,

I'm not able to reproduce.  I create a folder, place my .story file in it.  Inside that project folder, I create another folder where I place my web object.  When I publish, I'm seeing the folder.  Are you working off a network drive, or is it all local?  It may be worth submitting a case for our tech team to look at.  You can record a screenvideo when you do, and then we can take a look.

http://www.articulate.com/support/contact/

Mike