Articulate Storyline Error Report

Hi everyone,

 

Each time I try to publish a course I get a pop up saying "Articulate Storyline Error Report.  Were sorry, something went wrong with Articulate Storyline and it might close.  You can help up fix this bug by sending us information on what went wrong.  "

 

I sent numerous error reports but nobody has responded back.  Have any of you had this issue? Is there someone at Articulate that would publish my course for me and send me the file? I need to place it on LMS.

 

 

29 Replies
Ali Goulet

Hi A!

Sorry you're seeing this issue, thanks for letting us know here. Is this happening with just one course you're trying to publish or any course at all? You may want to try importing your slides into a new course if the former is the case. If the latter is the case, however, running this repair on your software should resolve the issue. 

Please let me know how that goes! If you're still having difficulty after trying those, you're welcome to share your .story project file here in a comment in this thread using the "Add Attachment" feature. Just let me know what settings you're using for publishing. Thanks! 

Crystal Horn

A- Ali posted some good stuff here (she beat me to the punch)   :)

But I wanted to also mention that sending the error report generates some information for our Quality Assurance team to help them investigate potential bugs.  I'm sorry if the verbiage of that message was confusing.

But our support department is available 24/7 to work with you on a case.  And we moderate these forums Monday through Friday EST business hours.

Alyssa Gomez

Hi there Ra,

Sorry to hear you're having trouble publishing. You may want to try importing your slides into a new course, and if you are still seeing issues, running this repair on your software

Let me know how that goes! You're also welcome to get in touch with our Support Engineers, and they'll help you one-on-one to get to the bottom of this. :)

David Wirth

I'm getting the Articulate Storyline Error Report popup now ever since I upgraded to Studio 360. Now I can't hit any dropdown buttons at all without getting this error in both Storyline or Studio. Everything was working fine until I installed studio but uninstalling did not help.

I have uninstalled and re-installed Storyline and even on a one page project it crashes when I hit a drop down.

 

Here is the error generated and I have opened a ticket as I'm essentially dead in the water:

 

<?xml version="1.0" encoding="utf-16"?>
<ErrorReport xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema">
  <FirstName />
  <LastName />
  <EmailAddress>EmailAddress>
  <MachineName></MachineName>
  <HardwareId>UA1D3-51SSD-CXMDC-9RP1T-V9U3F</HardwareId>
  <Message>Object reference not set to an instance of an object.</Message>
  <StackTrace>   at Articulate.Windows.Forms.Metro.MetroComboBox.q()
   at Articulate.Windows.Forms.Metro.MetroComboBox.WndProc(Message&amp; message)
   at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message&amp; m)
   at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message&amp; m)
   at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)</StackTrace>
</ErrorReport>

Alyssa Gomez

Hi there David,

I'm sorry to hear that you keep getting that error message. It sounds like you've already tried these steps for fixing unexpected behavior in Storyline 360 with no luck, but that was a good first step. I see that you're now working with my colleague Jonathan in your case (00999580); you're in good hands there! I'll follow along, and hopefully we can get this sorted out for you soon. :)

Alyssa Gomez

Hi Allan,

Thanks for checking in on this. It looks like David was using Storyline 360 on a Windows 7 computer with a Windows Classic system theme. This causes an error report, and we're working on a fix for this issue. In the meantime, the recommendation is to switch to an Aero theme or a Windows Basic theme. Are you also using a Windows 7 machine?

I see that my colleague Vira has taken your case, so you should hear from her shortly!

Daniel Toomey

I had a similar issue. I tried to import the slide to a new project, and moved the original to the desktop, but I was still unable to publish or preview the entire project. Then I selected preview for each scene, and received the same error message on the last scene with the results slide. Turns out all the links were broken, so I reset them and was able to publish the project. I saw a similar suggestion somewhere on here to try to find issues via previewing individual slides or scenes. Shout-out to whoever that was!

Jason Fletcher

I've encountered the same problem, but I haven't been able to resolve it. I'm getting the error message whenever I try to publish or if I try to edit some of the Engage interactions. The problem only started yesterday. Some things I've done which may have contributed - copied the project from my desktop to a folder on my home network drive; copied some interactions from one scene to another and changed them. I've followed the suggestions above, including importing into a new project, removing the most recently added scene (the one that had the slides I'd copied from elsewhere in the course) to no avail. At this stage it's looking like the project I've been working on for the past month is toast. Any tips or suggestions gratefully received. Thanks.

Ali Goulet

Hey Jason,

So sorry that's happening! It sounds like you've been doing a ton of troubleshooting already on this, thanks for providing all those details here. I'm happy to help!

Moving the course back to your desktop was a great step, as we recommend to always work locally. 

To best help here, I have a couple questions to start with:

  1. Is this happening with only one course in particular, or are you seeing it happen in with multiple files? 
  2. You mentioned Engage interactions, so I just want to verify- Are you working in Storyline or Studio?

Keep me posted!

Jason Fletcher

Hi Ali,

Thanks for your kind offer to help. To answer your questions...

  1. I've just created a new project (with no content) and was able to publish it.
  2. I'm using Storyline 360. When I started building this course, I was using Engage to create new interactions and importing them into the Storyline course. More recently I've been copying earlier slides in Storyline that had Engage interactions that I wanted to reuse (with new content), and pasting them into my timeline, then selecting the interaction and choosing the Edit in Engage button.
Jason Fletcher

I've got a hunch that the bug might have been caused by me copying slides that had Engage interactions on them, and pasting them in later on my Storyline course, then editing them to make them new slides. When I select to edit them in Engage, they're showing up with the original file name at the top of the screen, so I have multiple versions of the same file inserted into my project, but all different from one another. Does that sound like it might be the problem?

Jason Fletcher

Hi Ashley - that's how I have been using Engage up until last week, when I noticed that one of my earlier Engage interactions could be modified to create a new one, so cut and pasted it. The inability to publish occurred soon after, which may have been coincidental, but could be the reason.

Jason Fletcher

Thanks to the talented Vevette at Articuate, my problem has been solved!

It looks likely that two of the Engage interactions that I'd copied from earlier in my Storyline project and pasted in and edited had become corrupted. By deleted these two slides (which Vevette cleverly identified), I was able to recreate them in Engage and import them in as new slides. Voila - my course could be published again. There was much rejoicing!

The lesson learnt - don't duplicate or copy/paste slides with Engage interactions. Instead create them from scratch in Engage (or open an existing Engage file and Save As), and then import it into Storyline. I've been doing this on the same Storyline project with no further issues.

Thanks again.