Audio Controls?

I am working on a project where I have inserted several audio files on a slide and have a button to lauch each audio clip - In this case, I have 2 separate buttons launching 2 separate audio files.  My delimma is that once published, the users can click each button one right after another and have all 3 audio clips playing at the same time with no way to pause/stop any of the clips. I tried republishing and adding the Seekbar but that doesn't control the audio.

Is there any type of audio control tool inside Storyline? I haven't found anything yet. I just want to be able to Start/Stop/ and Pause each audio clip. I'm attaching a screenshot of the slide showing the audio buttons.

Thanks!

8 Replies
Bj Wilson

This response may help you. 

If you use a trigger to play audio in Articulate Storyline, learners won't be able to use the seekbar to control how the audio plays—i.e., they won't be able to scrub back-and-forth through the narration. Audio that plays only when triggered is divorced from the slide's timeline, since it requires certain conditions to be met first (such as clicking a button).

www.articulate.com/support/storyline/seekbar-doesnt-control-triggered-audio

To trigger audio and control its playback, do the following:

Add a layer to your slide. (You don't need to add any elements to the layer unless you want to. It can be blank.)
Import your audio to the new layer. (Use the default timing, so it'll start at the beginning of the layer's timeline.)
Click the gear icon (the Properties button) for the layer, and do the following:Mark the box to Hide slide layer when the timeline finishes.
Use the Allow seeking drop-down to select Yes.
Click OK.
Modify your original trigger so that it shows the new layer (rather than playing the audio).

Jill McNair

Hi Kimberly,

I would follow BJ's advice, and I would also put each audio on it's own layer.  I addition, when setting the slide properties, I would check the "Pause timeline of base layer" box.  This will pause the audio on the base layer, in case they click on the audio button(s) before the base layer narration is completed.

Hope it helps!

Jill

Kimberly Lococo

Hi,

I tried adding the audio file to its own separate layer per the steps you described but still not fully getting this to work the way I want.

Let me try providing more explanation:

The slide I am currently working on already has three layers of content. Each content layer has a button to click to listen to an audio clip AFTER reading the content on the layer. (Some of the layers have mulitple audio clip buttons.) Previously, I had the audio file loaded to each layer with the button trigger to launch the audio.

I just tried the steps you advised on one of the files and created a new layer just for the audio file and changed the audio button trigger to now show the new layer when clicking the button, and I set the properties you advised. However, in PREVIEW mode, the audio now starts immediatly after going to the content layer instead of waiting to click to audio button. I want the students to read the content on the layer first and then click the button to launch the audio. 

I set those "gear" icon properties on the audio only layer. Do I need to set the properties on the content layer?  I'm attaching a screenshot showing i'm on the Agent 3 layer and the Buttont triggers are set to show the audio layer when clicking the button. 

Is there any plans to provide separate audio controls in the future for Storyline when adding audio files?  This is a lot of workaround to be able to control audio when you want several audio clips on a slide.

Thanks!

Philip Foster

I've been working on the same issue today.  I have different layers, each with an audio file in the timeline.  My example has several tabs that show different steps of a procedure and each is narrated. One trigger on a layer starts the audio. Another trigger stops the audio when (State of) any of the elements on that layer are hidden.  

I can click any tab and the audio plays and the previous audio stops.

The only problem I'm having is that one audio clip does not start playing.  All others start and stop as desired. Go figure...

Philip Foster

One more thing - I set the base layer settings to custom player controls and enabled seeking. Then, on each slide layer, I set Allow Seeking to "yes."  Now the audio seek bar behaves as expected.

(Solved the other problem where on audio would not play:  one object on the timeline did not start at zero as it should.  It would be wiser to only stop audio when only one element is hidden.)